summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristopher Baines <mail@cbaines.net>2018-02-05 11:16:21 +0000
committerChristopher Baines <mail@cbaines.net>2018-12-31 10:14:46 +0000
commit48135a303420dc7b5e2b4958f16281cb81031f72 (patch)
treee061dd4afae37cdeb1facd67a9ca015c5dadcb97
parentf7d073140b9b4920c5351cb209b3f593cfea98a7 (diff)
downloadgnu-guix-48135a303420dc7b5e2b4958f16281cb81031f72.tar
gnu-guix-48135a303420dc7b5e2b4958f16281cb81031f72.tar.gz
gnu: Add ruby-hamster.
-rw-r--r--gnu/packages/ruby.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index 547759e237..31edef4481 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -8625,3 +8625,27 @@ but it can function as a stand-alone templating engine.")
"open child process with handles on pid, stdin, stdout, and stderr: manage child processes and their io handles easily.")
(home-page "https://github.com/ahoward/open4")
(license #f)))
+
+(define-public ruby-hamster
+ (package
+ (name "ruby-hamster")
+ (version "3.0.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (rubygems-uri "hamster" version))
+ (sha256
+ (base32
+ "1n1lsh96vnyc1pnzyd30f9prcsclmvmkdb3nm5aahnyizyiy6lar"))))
+ (build-system ruby-build-system)
+ (arguments
+ '(#:tests? #f))
+ (propagated-inputs
+ `(("ruby-concurrent" ,ruby-concurrent)))
+ (synopsis
+ "Efficient, immutable, thread-safe collection classes for Ruby")
+ (description
+ "Efficient, immutable, thread-safe collection classes for Ruby")
+ (home-page
+ "https://github.com/hamstergem/hamster")
+ (license license:expat)))