summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Enge <andreas@enge.fr>2013-09-22 17:25:12 +0200
committerAndreas Enge <andreas@enge.fr>2013-09-22 17:25:12 +0200
commit477c91ce736b28b39a9a46a310f905b78dd45dfb (patch)
tree23fcd5f7724bcac8da2bbf61f9a87189426edab6
parent144f9f251dd596897b9f8e1710c5dc7a21c92404 (diff)
downloadgnu-guix-477c91ce736b28b39a9a46a310f905b78dd45dfb.tar
gnu-guix-477c91ce736b28b39a9a46a310f905b78dd45dfb.tar.gz
gnu: Add gst-plugins-base.
* gnu/packages/gstreamer.scm (gst-plugins-base): New variable.
-rw-r--r--gnu/packages/gstreamer.scm44
1 files changed, 44 insertions, 0 deletions
diff --git a/gnu/packages/gstreamer.scm b/gnu/packages/gstreamer.scm
index 085061fe90..7478dc3188 100644
--- a/gnu/packages/gstreamer.scm
+++ b/gnu/packages/gstreamer.scm
@@ -63,3 +63,47 @@ simple plugin with a clean, generic interface.
This package provides the core library and elements.")
(license lgpl2.0+)))
+
+(define-public gst-plugins-base
+ (package
+ (name "gst-plugins-base")
+ (version "1.0.10")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "http://gstreamer.freedesktop.org/src/gst-plugins-base/gst-plugins-base-"
+ version ".tar.xz"))
+ (sha256
+ (base32
+ "1s4pphbb5kpdh4rrmb8rala4sp499k4by59925k15xiz58xyhm4p"))))
+ (build-system gnu-build-system)
+ ;; FIXME: Add more dependencies for further plugins.
+ (inputs
+ `(("glib" ,glib)
+ ("gstreamer" ,gstreamer)
+ ("pkg-config" ,pkg-config)
+ ("python-wrapper" ,python-wrapper)))
+ (arguments
+ `(#:tests? #f))
+ ;; All tests pass except for one:
+ ;; Running suite(s): pbutils library
+ ;; 85%: Checks: 7, Failures: 1, Errors: 0
+ ;; libs/pbutils.c:522:F:general:test_pb_utils_install_plugins:0: gst_install_plugins_sync() failed ;; with unexpected ret 201, which is neither HELPER_MISSING nor 1
+ ;; FAIL: libs/pbutils
+ ;; According to the documentation, "gst_install_plugins_sync (...)
+ ;; should almost never be used".
+ (home-page "http://gstreamer.freedesktop.org/")
+ (synopsis
+ "Plugins for the gstreamer multimedia library")
+ (description
+ "GStreamer is a library for constructing graphs of media-handling
+components. The applications it supports range from simple Ogg/Vorbis
+playback, audio/video streaming to complex audio (mixing) and video
+(non-linear editing) processing.
+
+Applications can take advantage of advances in codec and filter technology
+transparently. Developers can add new codecs and filters by writing a
+simple plugin with a clean, generic interface.
+
+This package provides an essential exemplary set of elements.")
+ (license lgpl2.0+)))