summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristopher Baines <mail@cbaines.net>2018-03-24 10:57:10 +0000
committerChristopher Baines <mail@cbaines.net>2018-12-31 09:22:54 +0000
commit3e7de7ce4fc696a78fa0107ac1f3c304a25f936a (patch)
tree2d79e11e87866775b18166c3ab71081bc5353a4e
parent7de4b1d777e5a65d7f9e2dbbb1c1d1eae14a2893 (diff)
downloadgnu-guix-3e7de7ce4fc696a78fa0107ac1f3c304a25f936a.tar
gnu-guix-3e7de7ce4fc696a78fa0107ac1f3c304a25f936a.tar.gz
gnu: Add python-restructuredtext-lint.
-rw-r--r--gnu/packages/python.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 25de69d868..9a6de42041 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -15526,3 +15526,26 @@ class in a @acronym{DRY, Don't Repeat Yourself} way.")
(description
"Test your project's packaging friendliness")
(license license:expat)))
+
+(define-public python-restructuredtext-lint
+ (package
+ (name "python-restructuredtext-lint")
+ (version "1.1.3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "restructuredtext_lint" version))
+ (sha256
+ (base32
+ "0ds05cc5qx1gagwy3cvr93pckvgsvi3zwhgh14l2cari9jlak364"))))
+ (build-system python-build-system)
+ (arguments
+ '(#:tests? #f))
+ (propagated-inputs
+ `(("python-docutils"
+ ,python-docutils)))
+ (home-page
+ "https://github.com/twolfson/restructuredtext-lint")
+ (synopsis "reStructuredText linter")
+ (description "reStructuredText linter")
+ (license #f)))