summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2015-06-12 15:47:18 +0200
committerRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2015-06-26 15:29:01 +0200
commit3a1bfe186df738600068615baa3df59211248b6b (patch)
treedeb1525fac58a10dce83c43146e40cee870cf4fe
parent0dde623211096642013bf05879982214dfb08b25 (diff)
downloadgnu-guix-3a1bfe186df738600068615baa3df59211248b6b.tar
gnu-guix-3a1bfe186df738600068615baa3df59211248b6b.tar.gz
gnu: Add python2-fastlmm.
* gnu/packages/python.scm (python2-fastlmm): New variable.
-rw-r--r--gnu/packages/python.scm36
1 files changed, 36 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 7ddfcc6ffe..1b3934b351 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -2326,6 +2326,42 @@ capabilities.")
(define python2-numpy-bootstrap
(package-with-python2 python-numpy-bootstrap))
+(define-public python2-fastlmm
+ (package
+ (name "python2-fastlmm")
+ (version "0.2.14")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://pypi.python.org/packages/source/f/fastlmm"
+ "/fastlmm-" version ".zip"))
+ (sha256
+ (base32
+ "023sydkrc3yxad2bycar02jfswwlh4199kafzhf2bssyx2c3xa0l"))))
+ (build-system python-build-system)
+ (arguments
+ `(#:python ,python-2)) ; only Python 2.7 is supported
+ (propagated-inputs
+ `(("python2-numpy" ,python2-numpy)
+ ("python2-scipy" ,python2-scipy)
+ ("python2-matplotlib" ,python2-matplotlib)
+ ("python2-pandas" ,python2-pandas)
+ ("python2-scikit-learn" ,python2-scikit-learn)
+ ("python2-cython" ,python2-cython)
+ ("python2-pysnptools" ,python2-pysnptools)))
+ (native-inputs
+ `(("unzip" ,unzip)
+ ("python2-mock" ,python2-mock)
+ ("python2-setuptools" ,python2-setuptools)))
+ (home-page "http://research.microsoft.com/en-us/um/redmond/projects/mscompbio/fastlmm/")
+ (synopsis "Perform genome-wide association studies on large data sets")
+ (description
+ "FaST-LMM, which stands for Factored Spectrally Transformed Linear Mixed
+Models, is a program for performing both single-SNP and SNP-set genome-wide
+association studies (GWAS) on extremely large data sets.")
+ (license asl2.0)))
+
(define-public python-numpy
(package (inherit python-numpy-bootstrap)
(name "python-numpy")