summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJulien Lepiller <julien@lepiller.eu>2018-11-19 23:28:21 +0100
committerJulien Lepiller <julien@lepiller.eu>2018-12-18 22:17:12 +0100
commit34d5314e9c826b1f602f9aaa8d707ca594736aaf (patch)
tree5519181d0f471b5d7fdd8c897bd0ea3295f0849f
parent426e629e0c5829b0ac8987660c38eeb121f55675 (diff)
downloadgnu-guix-34d5314e9c826b1f602f9aaa8d707ca594736aaf.tar
gnu-guix-34d5314e9c826b1f602f9aaa8d707ca594736aaf.tar.gz
gnu: ocaml-lambda-term: Use dune-build-system.
* gnu/packages/ocaml.scm (ocaml-lambda-term): Use dune-build-system.
-rw-r--r--gnu/packages/ocaml.scm17
1 files changed, 2 insertions, 15 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index 927c1ed8ff..3b1ddcb5b6 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -4508,23 +4508,10 @@ connect an engine to your inputs and rendering functions to get an editor.")
(file-name (string-append name "-" version ".tar.gz"))
(sha256
(base32 "1hy5ryagqclgdm9lzh1qil5mrynlypv7mn6qm858hdcnmz9zzn0l"))))
- (build-system ocaml-build-system)
+ (build-system dune-build-system)
(arguments
- `(#:phases
- (modify-phases %standard-phases
- (delete 'configure)
- (replace 'build
- (lambda _
- (invoke "dune" "build" "@install" "--profile" "release")
- #t))
- (replace 'install
- (lambda* (#:key outputs #:allow-other-keys)
- (invoke "dune" "install"
- "--prefix" (assoc-ref outputs "out"))
- #t)))
+ `(#:build-flags (list "--profile" "release")
#:tests? #f))
- (native-inputs
- `(("dune" ,dune)))
(propagated-inputs
`(("lwt" ,ocaml-lwt)
("lwt-log" ,ocaml-lwt-log)