summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristopher Baines <mail@cbaines.net>2018-03-24 10:54:41 +0000
committerChristopher Baines <mail@cbaines.net>2018-12-31 09:22:53 +0000
commit150a49e2df87f5020dfb538afe8178a8cc895495 (patch)
tree664b66a4d3efeadec3a19124e922d8bc3fe27ef4
parentbda77ea6a346fccc6e9c7e842fdd345a93d94c25 (diff)
downloadgnu-guix-150a49e2df87f5020dfb538afe8178a8cc895495.tar
gnu-guix-150a49e2df87f5020dfb538afe8178a8cc895495.tar.gz
gnu: Add python-autoflake.
-rw-r--r--gnu/packages/python.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 0c13e39f5f..d0eb3a2ca0 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -15253,3 +15253,24 @@ class in a @acronym{DRY, Don't Repeat Yourself} way.")
(description
"Linting and Fixing Code for All Languages")
(license #f)))
+
+(define-public python-autoflake
+ (package
+ (name "python-autoflake")
+ (version "1.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "autoflake" version))
+ (sha256
+ (base32
+ "0cfidqg3msagg92l1hbc644nih0n615c5p9ab1s4yr82g956hkd7"))))
+ (build-system python-build-system)
+ (propagated-inputs
+ `(("python-pyflakes" ,python-pyflakes)))
+ (home-page "https://github.com/myint/autoflake")
+ (synopsis
+ "Removes unused imports and unused variables")
+ (description
+ "Removes unused imports and unused variables")
+ (license #f)))