summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py9
1 files changed, 7 insertions, 2 deletions
diff --git a/setup.py b/setup.py
index f637a48..003dd08 100755
--- a/setup.py
+++ b/setup.py
@@ -35,7 +35,7 @@ PACKAGE = 'factory'
setup(
name='factory_boy',
version=get_version(PACKAGE),
- description="A verstile test fixtures replacement based on thoughtbot's factory_girl for Ruby.",
+ description="A versatile test fixtures replacement based on thoughtbot's factory_girl for Ruby.",
author='Mark Sandstrom',
author_email='mark@deliciouslynerdy.com',
maintainer='Raphaƫl Barrois',
@@ -44,6 +44,9 @@ setup(
keywords=['factory_boy', 'factory', 'fixtures'],
packages=['factory'],
license='MIT',
+ install_requires=[
+ 'fake-factory>=0.5.0',
+ ],
setup_requires=[
'setuptools>=0.8',
],
@@ -63,9 +66,11 @@ setup(
"Programming Language :: Python :: 3",
"Programming Language :: Python :: 3.2",
"Programming Language :: Python :: 3.3",
+ "Programming Language :: Python :: 3.4",
+ "Programming Language :: Python :: 3.5",
"Programming Language :: Python :: Implementation :: PyPy",
"Topic :: Software Development :: Testing",
- "Topic :: Software Development :: Libraries :: Python Modules"
+ "Topic :: Software Development :: Libraries :: Python Modules",
],
test_suite='tests',
test_loader=test_loader,