diff options
Diffstat (limited to 'setup.py')
-rwxr-xr-x | setup.py | 5 |
1 files changed, 3 insertions, 2 deletions
@@ -1,6 +1,7 @@ #!/usr/bin/env python # -*- coding: utf-8 -*- +import codecs import os import re import sys @@ -13,8 +14,8 @@ root_dir = os.path.abspath(os.path.dirname(__file__)) def get_version(package_name): version_re = re.compile(r"^__version__ = [\"']([\w_.-]+)[\"']$") package_components = package_name.split('.') - path_components = package_components + ['__init__.py'] - with open(os.path.join(root_dir, *path_components)) as f: + init_path = os.path.join(root_dir, *(package_components + ['__init__.py'])) + with codecs.open(init_path, 'r', 'utf-8') as f: for line in f: match = version_re.match(line[:-1]) if match: |