summaryrefslogtreecommitdiff
path: root/factory/__init__.py
diff options
context:
space:
mode:
Diffstat (limited to 'factory/__init__.py')
-rw-r--r--factory/__init__.py56
1 files changed, 32 insertions, 24 deletions
diff --git a/factory/__init__.py b/factory/__init__.py
index 1d4408f..e1138fa 100644
--- a/factory/__init__.py
+++ b/factory/__init__.py
@@ -1,6 +1,6 @@
# -*- coding: utf-8 -*-
# Copyright (c) 2010 Mark Sandstrom
-# Copyright (c) 2011 Raphaël Barrois
+# Copyright (c) 2011-2013 Raphaël Barrois
#
# Permission is hereby granted, free of charge, to any person obtaining a copy
# of this software and associated documentation files (the "Software"), to deal
@@ -20,51 +20,59 @@
# OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN
# THE SOFTWARE.
-__version__ = '1.1.2' # Remember to change in setup.py as well!
-__author__ = 'Raphaël Barrois <raphael.barrois@polytechnique.org>'
+__version__ = '2.0.2'
+__author__ = 'Raphaël Barrois <raphael.barrois+fboy@polytechnique.org>'
-from base import (
+from .base import (
Factory,
+ BaseDictFactory,
+ DictFactory,
+ BaseListFactory,
+ ListFactory,
+ MogoFactory,
StubFactory,
DjangoModelFactory,
- build,
- create,
- stub,
- generate,
- simple_generate,
- make_factory,
-
- build_batch,
- create_batch,
- stub_batch,
- generate_batch,
- simple_generate_batch,
-
BUILD_STRATEGY,
CREATE_STRATEGY,
STUB_STRATEGY,
-
- DJANGO_CREATION,
- NAIVE_BUILD,
- MOGO_BUILD,
+ use_strategy,
)
-from declarations import (
+from .declarations import (
LazyAttribute,
Iterator,
- InfiniteIterator,
Sequence,
LazyAttributeSequence,
SelfAttribute,
ContainerAttribute,
SubFactory,
+ Dict,
+ List,
+ PostGeneration,
+ PostGenerationMethodCall,
+ RelatedFactory,
+)
+
+from .helpers import (
+ build,
+ create,
+ stub,
+ generate,
+ simple_generate,
+ make_factory,
+
+ build_batch,
+ create_batch,
+ stub_batch,
+ generate_batch,
+ simple_generate_batch,
lazy_attribute,
iterator,
- infinite_iterator,
sequence,
lazy_attribute_sequence,
container_attribute,
+ post_generation,
)