aboutsummaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog26
-rw-r--r--debian/compat1
-rw-r--r--debian/control26
-rw-r--r--debian/copyright24
-rw-r--r--debian/gbp.conf8
-rwxr-xr-xdebian/rules23
-rw-r--r--debian/source/format1
-rw-r--r--debian/watch2
8 files changed, 111 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog
new file mode 100644
index 0000000..9593e28
--- /dev/null
+++ b/debian/changelog
@@ -0,0 +1,26 @@
+factory-boy (1.1.5-1) experimental; urgency=low
+
+ * New upstream release.
+ * Added a get-vcs-source and debian/gbp.conf file.
+ * Added everyone in the team as uploaders.
+
+ -- Thomas Goirand <zigo@debian.org> Sun, 14 Oct 2012 12:06:03 +0000
+
+factory-boy (1.1.3-1) unstable; urgency=low
+
+ * New upstream release
+ * Rename binary to python-factory-boy (Closes: #663397)
+
+ -- Ghe Rivero <ghe.rivero@stackops.com> Sat, 10 Mar 2012 23:20:09 +0100
+
+factory-boy (1.1.2-1) unstable; urgency=low
+
+ * New upstream release
+
+ -- Ghe Rivero <ghe.rivero@stackops.com> Mon, 05 Mar 2012 19:13:53 +0100
+
+factory-boy (1.0.4-1) unstable; urgency=low
+
+ * Initial release.
+
+ -- Ghe Rivero <ghe.rivero@stackops.com> Tue, 14 Feb 2012 11:54:35 +0100
diff --git a/debian/compat b/debian/compat
new file mode 100644
index 0000000..7f8f011
--- /dev/null
+++ b/debian/compat
@@ -0,0 +1 @@
+7
diff --git a/debian/control b/debian/control
new file mode 100644
index 0000000..c14716e
--- /dev/null
+++ b/debian/control
@@ -0,0 +1,26 @@
+Source: factory-boy
+Section: python
+Priority: optional
+Maintainer: PKG OpenStack <openstack-devel@lists.alioth.debian.org>
+Uploaders: Loic Dachary (OuoU) <loic@debian.org>,
+ Julien Danjou <acid@debian.org>,
+ Thomas Goirand <zigo@debian.org>,
+ Ghe Rivero <ghe.rivero@stackops.com>,
+ Mehdi Abaakouk <sileht@sileht.net>
+Build-Depends: debhelper (>= 7.0.50), python-dev (>=2.6.6-3~)
+Standards-Version: 3.9.3
+Homepage: https://github.com/rbarrois/factory_boy
+Vcs-Browser: http://anonscm.debian.org/gitweb/?p=openstack/factory-boy.git;a=summary
+Vcs-Git: git://anonscm.debian.org/openstack/factory-boy.git
+X-Python-Version: >= 2.6
+
+Package: python-factory-boy
+Architecture: any
+Depends: ${shlibs:Depends}, ${misc:Depends}, ${python:Depends},
+Description: test fixtures replacement based on thoughtbot's factory_girl for Ruby.
+ factory_boy is a fixtures replacement based on thoughtbot's factory_girl . Like
+ factory_girl it has a straightforward definition syntax, support for multiple
+ build strategies (saved instances, unsaved instances, attribute dicts, and
+ stubbed objects), and support for multiple factories for the same class,
+ including factory inheritance.
+ Django support is included, and support for other ORMs can be easily added. \ No newline at end of file
diff --git a/debian/copyright b/debian/copyright
new file mode 100644
index 0000000..16bfecf
--- /dev/null
+++ b/debian/copyright
@@ -0,0 +1,24 @@
+Format: http://dep.debian.net/deps/dep5
+Upstream-Name: novnc
+Source: https://github.com/rbarrois/factory_boy
+
+Files: *
+Copyright: 2010 Mark Sandstrom
+License: MIT
+ Permission is hereby granted, free of charge, to any person obtaining a copy
+ of this software and associated documentation files (the "Software"), to deal
+ in the Software without restriction, including without limitation the rights
+ to use, copy, modify, merge, publish, distribute, sublicense, and/or sell
+ copies of the Software, and to permit persons to whom the Software is
+ furnished to do so, subject to the following conditions:
+ .
+ The above copyright notice and this permission notice shall be included in
+ all copies or substantial portions of the Software.
+ .
+ THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
+ IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
+ FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
+ AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
+ LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
+ OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN
+ THE SOFTWARE. \ No newline at end of file
diff --git a/debian/gbp.conf b/debian/gbp.conf
new file mode 100644
index 0000000..f9f4b78
--- /dev/null
+++ b/debian/gbp.conf
@@ -0,0 +1,8 @@
+[DEFAULT]
+upstream-branch = master
+debian-branch = debian/experimental
+upstream-tag = v%(version)s
+compression = xz
+
+[git-buildpackage]
+export-dir = ../build-area/
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 0000000..8f89ae3
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,23 @@
+#!/usr/bin/make -f
+
+# export DH_VERBOSE=1
+
+DEBVERS := $(shell dpkg-parsechangelog | sed -n -e 's/^Version: //p')
+VERSION := $(shell echo '$(DEBVERS)' | sed -e 's/^[[:digit:]]*://' -e 's/[~-].*//')
+DEBFLAVOR :=$(shell dpkg-parsechangelog | grep -E ^Distribution: | cut -d" " -f2)
+DEBPKGNAME :=$(shell dpkg-parsechangelog | grep -E ^Source: | cut -d" " -f2)
+
+%:
+ dh $@ --with python2
+
+get-vcs-source:
+ git remote add upstream git://github.com/rbarrois/factory_boy.git || true
+ git fetch upstream
+ if [ ! -f ../$(DEBPKGNAME)_$(VERSION).orig.tar.xz ] ; then \
+ git archive --prefix=$(DEBPKGNAME)-$(VERSION)/ $(VERSION) | xz >../$(DEBPKGNAME)_$(VERSION).orig.tar.xz ; \
+ fi
+ if ! git checkout master ; then \
+ echo "No upstream branch: checking out" ; \
+ git checkout -b master upstream/master ; \
+ fi
+ git checkout debian/experimental
diff --git a/debian/source/format b/debian/source/format
new file mode 100644
index 0000000..46ebe02
--- /dev/null
+++ b/debian/source/format
@@ -0,0 +1 @@
+3.0 (quilt) \ No newline at end of file
diff --git a/debian/watch b/debian/watch
new file mode 100644
index 0000000..8f839ca
--- /dev/null
+++ b/debian/watch
@@ -0,0 +1,2 @@
+version=3
+http://pypi.python.org/packages/source/f/factory_boy/factory_boy-(.+).tar.gz debian uupdate