summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules25
1 files changed, 21 insertions, 4 deletions
diff --git a/debian/rules b/debian/rules
index 99dbc84..a0f7e87 100755
--- a/debian/rules
+++ b/debian/rules
@@ -1,15 +1,32 @@
#!/usr/bin/make -f
-# export DH_VERBOSE=1
+PYTHONS:=$(shell pyversions -vr)
+PYTHON3S:=$(shell py3versions -vr)
UPSTREAM_GIT = git://github.com/rbarrois/factory_boy.git
-
include /usr/share/openstack-pkg-tools/pkgos.make
%:
- dh $@ --with python2 --buildsystem=python_distutils
+ dh $@ --buildsystem=python_distutils --with python2,python3,sphinxdoc
+
+override_dh_auto_install:
+ set -e && for pyvers in $(PYTHONS); do \
+ python$$pyvers setup.py install --install-layout=deb \
+ --root $(CURDIR)/debian/python-factory-boy; \
+ done
+ set -e && for pyvers in $(PYTHON3S); do \
+ python$$pyvers setup.py install --install-layout=deb \
+ --root $(CURDIR)/debian/python3-factory-boy; \
+ done
+override_dh_sphinxdoc:
+ifeq (,$(findstring nodocs, $(DEB_BUILD_OPTIONS)))
+ PYTHONPATH=. sphinx-build -b html docs $(CURDIR)/debian/python-factory-boy-doc/usr/share/doc/python-factory-boy-doc/html
+ dh_sphinxdoc -O--buildsystem=python_distutils
+endif
override_dh_auto_test:
ifeq (,$(findstring nocheck, $(DEB_BUILD_OPTIONS)))
- python -W default setup.py test
+ set -e && for i in $(PYTHONS) $(PYTHON3S) ; do \
+ python$$i -W default setup.py test ; \
+ done
endif