summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules19
1 files changed, 3 insertions, 16 deletions
diff --git a/debian/rules b/debian/rules
index 8f89ae3..137b5c6 100755
--- a/debian/rules
+++ b/debian/rules
@@ -2,22 +2,9 @@
# export DH_VERBOSE=1
-DEBVERS := $(shell dpkg-parsechangelog | sed -n -e 's/^Version: //p')
-VERSION := $(shell echo '$(DEBVERS)' | sed -e 's/^[[:digit:]]*://' -e 's/[~-].*//')
-DEBFLAVOR :=$(shell dpkg-parsechangelog | grep -E ^Distribution: | cut -d" " -f2)
-DEBPKGNAME :=$(shell dpkg-parsechangelog | grep -E ^Source: | cut -d" " -f2)
+UPSTREAM_GIT = git://github.com/rbarrois/factory_boy.git
+
+include /usr/share/openstack-pkg-tools/pkgos.make
%:
dh $@ --with python2
-
-get-vcs-source:
- git remote add upstream git://github.com/rbarrois/factory_boy.git || true
- git fetch upstream
- if [ ! -f ../$(DEBPKGNAME)_$(VERSION).orig.tar.xz ] ; then \
- git archive --prefix=$(DEBPKGNAME)-$(VERSION)/ $(VERSION) | xz >../$(DEBPKGNAME)_$(VERSION).orig.tar.xz ; \
- fi
- if ! git checkout master ; then \
- echo "No upstream branch: checking out" ; \
- git checkout -b master upstream/master ; \
- fi
- git checkout debian/experimental