summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules5
1 files changed, 5 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
index c450391..99dbc84 100755
--- a/debian/rules
+++ b/debian/rules
@@ -8,3 +8,8 @@ include /usr/share/openstack-pkg-tools/pkgos.make
%:
dh $@ --with python2 --buildsystem=python_distutils
+
+override_dh_auto_test:
+ifeq (,$(findstring nocheck, $(DEB_BUILD_OPTIONS)))
+ python -W default setup.py test
+endif