diff options
Diffstat (limited to 'Makefile')
-rw-r--r-- | Makefile | 10 |
1 files changed, 6 insertions, 4 deletions
@@ -2,6 +2,8 @@ PACKAGE=factory TESTS_DIR=tests DOC_DIR=docs +# Use current python binary instead of system default. +COVERAGE = python $(shell which coverage) all: default @@ -20,10 +22,10 @@ pylint: pylint --rcfile=.pylintrc --report=no $(PACKAGE)/ coverage: - coverage erase - coverage run "--include=$(PACKAGE)/*.py,$(TESTS_DIR)/*.py" --branch setup.py test - coverage report "--include=$(PACKAGE)/*.py,$(TESTS_DIR)/*.py" - coverage html "--include=$(PACKAGE)/*.py,$(TESTS_DIR)/*.py" + $(COVERAGE) erase + $(COVERAGE) run "--include=$(PACKAGE)/*.py,$(TESTS_DIR)/*.py" --branch setup.py test + $(COVERAGE) report "--include=$(PACKAGE)/*.py,$(TESTS_DIR)/*.py" + $(COVERAGE) html "--include=$(PACKAGE)/*.py,$(TESTS_DIR)/*.py" doc: $(MAKE) -C $(DOC_DIR) html |