summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--MANIFEST.in16
-rw-r--r--Makefile1
-rw-r--r--tox.ini4
3 files changed, 15 insertions, 6 deletions
diff --git a/MANIFEST.in b/MANIFEST.in
index 22f4a5c..19b0f8c 100644
--- a/MANIFEST.in
+++ b/MANIFEST.in
@@ -1,8 +1,12 @@
-include README.rst
+include ChangeLog LICENSE README.rst
include requirements*.txt
-include docs/Makefile
-recursive-include docs *.py *.rst
-include docs/_static/.keep_dir
-prune docs/_build
-recursive-include tests *.py *.data
+graft factory
+
+prune docs
+prune examples
+prune tests
+
+global-exclude .py[cod] __pycache__
+
+exclude Makefile tox.ini .pylintrc
diff --git a/Makefile b/Makefile
index de0243f..8f48c6b 100644
--- a/Makefile
+++ b/Makefile
@@ -34,6 +34,7 @@ example-test:
$(MAKE) -C $(EXAMPLES_DIR) test
lint:
+ check-manifest
pylint --rcfile=.pylintrc --report=no $(PACKAGE)/
coverage:
diff --git a/tox.ini b/tox.ini
index bbcf538..4ccade6 100644
--- a/tox.ini
+++ b/tox.ini
@@ -31,5 +31,9 @@ whitelist_externals = make
commands = make example-test
[testenv:lint]
+deps =
+ pylint
+ check_manifest
+
whitelist_externals = make
commands = make lint