summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--.travis.yml1
-rw-r--r--README2
-rwxr-xr-xsetup.py1
3 files changed, 3 insertions, 1 deletions
diff --git a/.travis.yml b/.travis.yml
index e32214b..d0735d8 100644
--- a/.travis.yml
+++ b/.travis.yml
@@ -5,6 +5,7 @@ python:
- "2.7"
- "3.2"
- "3.3"
+ - "pypy"
script:
- python setup.py test
diff --git a/README b/README
index a4629af..3756109 100644
--- a/README
+++ b/README
@@ -22,7 +22,7 @@ Links
* Official repository: https://github.com/rbarrois/factory_boy
* Package: https://pypi.python.org/pypi/factory_boy/
-factory_boy supports Python 2.6, 2.7, 3.2 and 3.3; and requires only the standard Python library.
+factory_boy supports Python 2.6, 2.7, 3.2 and 3.3, as well as PyPy; it requires only the standard Python library.
Download
diff --git a/setup.py b/setup.py
index 1cb2e91..050e43b 100755
--- a/setup.py
+++ b/setup.py
@@ -90,6 +90,7 @@ setup(
'Programming Language :: Python :: 3',
'Programming Language :: Python :: 3.2',
'Programming Language :: Python :: 3.3',
+ 'Programming Language :: Python :: Implementation :: PyPy',
'Topic :: Software Development :: Testing',
'Topic :: Software Development :: Libraries :: Python Modules'
],