summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--.travis.yml2
-rw-r--r--tests/test_mongoengine.py3
2 files changed, 4 insertions, 1 deletions
diff --git a/.travis.yml b/.travis.yml
index ed331d4..e1600bd 100644
--- a/.travis.yml
+++ b/.travis.yml
@@ -6,7 +6,7 @@ python:
- "pypy"
script:
- - python setup.py test
+ - SKIP_MONGOENGINE=1 python setup.py test
install:
- make install-deps
diff --git a/tests/test_mongoengine.py b/tests/test_mongoengine.py
index 6fa4125..7badd43 100644
--- a/tests/test_mongoengine.py
+++ b/tests/test_mongoengine.py
@@ -31,6 +31,9 @@ try:
except ImportError:
mongoengine = None
+if os.environ.get('SKIP_MONGOENGINE') == 1:
+ mongoengine = None
+
if mongoengine:
from factory.mongoengine import MongoEngineFactory