summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--setup.py34
-rw-r--r--tests/__init__.py3
-rw-r--r--tests/test_base.py (renamed from factory/test_base.py)4
-rw-r--r--tests/test_containers.py (renamed from factory/test_containers.py)6
-rw-r--r--tests/test_declarations.py (renamed from factory/test_declarations.py)2
5 files changed, 42 insertions, 7 deletions
diff --git a/setup.py b/setup.py
index 0933245..6f0dfed 100644
--- a/setup.py
+++ b/setup.py
@@ -2,10 +2,41 @@
# -*- coding: utf-8 -*-
from distutils.core import setup
+from distutils import cmd
# Remember to change in factory/__init__.py as well!
VERSION = '1.0.4'
+
+class test(cmd.Command):
+ """Run the tests for this package."""
+ command_name = 'test'
+ description = 'run the tests associated with the package'
+
+ user_options = [
+ ('test-suite=', None, "A test suite to run (defaults to 'tests')"),
+ ]
+
+ def initialize_options(self):
+ self.test_runner = None
+ self.test_suite = None
+
+ def finalize_options(self):
+ self.ensure_string('test_suite', 'tests')
+
+ def run(self):
+ """Run the test suite."""
+ import unittest
+ if self.verbose:
+ verbosity=1
+ else:
+ verbosity=0
+
+ suite = unittest.TestLoader().loadTestsFromName(self.test_suite)
+
+ unittest.TextTestRunner(verbosity=verbosity).run(suite)
+
+
setup(
name='factory_boy_rbarrois',
version=VERSION,
@@ -25,5 +56,6 @@ setup(
'Programming Language :: Python',
'Topic :: Software Development :: Testing',
'Topic :: Software Development :: Libraries :: Python Modules'
- ]
+ ],
+ cmdclass={'test': test},
)
diff --git a/tests/__init__.py b/tests/__init__.py
new file mode 100644
index 0000000..642caeb
--- /dev/null
+++ b/tests/__init__.py
@@ -0,0 +1,3 @@
+from .test_base import *
+from .test_containers import *
+from .test_declarations import *
diff --git a/factory/test_base.py b/tests/test_base.py
index 783e041..17d9a9b 100644
--- a/factory/test_base.py
+++ b/tests/test_base.py
@@ -20,8 +20,8 @@
import unittest
-from base import BaseFactory, Factory, StubFactory, BUILD_STRATEGY, CREATE_STRATEGY, STUB_STRATEGY
-import declarations
+from factory.base import BaseFactory, Factory, StubFactory, BUILD_STRATEGY, CREATE_STRATEGY, STUB_STRATEGY
+from factory import declarations
class TestObject(object):
def __init__(self, one=None, two=None, three=None, four=None):
diff --git a/factory/test_containers.py b/tests/test_containers.py
index 9cc0378..b1485b1 100644
--- a/factory/test_containers.py
+++ b/tests/test_containers.py
@@ -20,9 +20,9 @@
import unittest
-import base
-import containers
-import declarations
+from factory import base
+from factory import containers
+from factory import declarations
class LazyStubTestCase(unittest.TestCase):
def test_basic(self):
diff --git a/factory/test_declarations.py b/tests/test_declarations.py
index f692ccf..6299396 100644
--- a/factory/test_declarations.py
+++ b/tests/test_declarations.py
@@ -20,7 +20,7 @@
import unittest
-from declarations import OrderedDeclaration, Sequence
+from factory.declarations import OrderedDeclaration, Sequence
class OrderedDeclarationTestCase(unittest.TestCase):
def test_errors(self):