summaryrefslogtreecommitdiff
path: root/.travis.yml
diff options
context:
space:
mode:
Diffstat (limited to '.travis.yml')
-rw-r--r--.travis.yml11
1 files changed, 4 insertions, 7 deletions
diff --git a/.travis.yml b/.travis.yml
index 2bfb978..ff805b0 100644
--- a/.travis.yml
+++ b/.travis.yml
@@ -1,19 +1,16 @@
language: python
python:
- - "2.6"
- "2.7"
- - "3.2"
- - "3.3"
+ - "3.4"
+ - "3.5"
- "pypy"
script:
- - python setup.py test
+ - SKIP_MONGOENGINE=1 python setup.py test
install:
- - if [[ $TRAVIS_PYTHON_VERSION = 2.6 ]]; then pip install unittest2 --use-mirrors; fi
- - pip install Django sqlalchemy --use-mirrors
- - if ! python --version 2>&1 | grep -q -i pypy ; then pip install Pillow --use-mirrors; fi
+ - make install-deps
notifications:
email: false