summaryrefslogtreecommitdiff
path: root/tox.ini
diff options
context:
space:
mode:
authorMikhail Korobov <kmike84@gmail.com>2012-04-10 10:58:14 +0600
committerMikhail Korobov <kmike84@gmail.com>2012-04-10 10:58:14 +0600
commitaf00973f82337a24aeececa2244ea3fc532db6d2 (patch)
tree8fb43d6b3fc60f5d651e0490b5f16219d5337cb1 /tox.ini
parente80cbdc3224297ee57667e4000f1a671af05f520 (diff)
downloadfactory-boy-af00973f82337a24aeececa2244ea3fc532db6d2.tar
factory-boy-af00973f82337a24aeececa2244ea3fc532db6d2.tar.gz
Test running improvements: tests can be run under python 2.6 (by using optional unittest2), tox config for testing under different pythons, explicit python version requirements (factory_boy works with python 2.6 and 2.7); ./setup.py test returns proper error code in case of test failure.
Diffstat (limited to 'tox.ini')
-rw-r--r--tox.ini11
1 files changed, 11 insertions, 0 deletions
diff --git a/tox.ini b/tox.ini
new file mode 100644
index 0000000..944070f
--- /dev/null
+++ b/tox.ini
@@ -0,0 +1,11 @@
+[tox]
+envlist = py26,py27,pypy
+
+[testenv]
+commands=
+ python setup.py test
+
+[testenv:py26]
+
+deps=
+ unittest2