summaryrefslogtreecommitdiff
path: root/tests/test_declarations.py
diff options
context:
space:
mode:
authorRaphaël Barrois <raphael.barrois@polytechnique.org>2011-12-21 01:01:59 +0100
committerRaphaël Barrois <raphael.barrois@polytechnique.org>2011-12-21 01:01:59 +0100
commit0cabe97af256c5b4ec72fc19a4ded7ac0f399c72 (patch)
tree30ff5fa01b698b7264d298812be3affd73210ef9 /tests/test_declarations.py
parent776674da04856635518d41de5375cea04f24d3d7 (diff)
downloadfactory-boy-0cabe97af256c5b4ec72fc19a4ded7ac0f399c72.tar
factory-boy-0cabe97af256c5b4ec72fc19a4ded7ac0f399c72.tar.gz
Add a 'test' command to the setup.py script.
Signed-off-by: Raphaël Barrois <raphael.barrois@polytechnique.org>
Diffstat (limited to 'tests/test_declarations.py')
-rw-r--r--tests/test_declarations.py31
1 files changed, 31 insertions, 0 deletions
diff --git a/tests/test_declarations.py b/tests/test_declarations.py
new file mode 100644
index 0000000..6299396
--- /dev/null
+++ b/tests/test_declarations.py
@@ -0,0 +1,31 @@
+# Copyright (c) 2010 Mark Sandstrom
+#
+# Permission is hereby granted, free of charge, to any person obtaining a copy
+# of this software and associated documentation files (the "Software"), to deal
+# in the Software without restriction, including without limitation the rights
+# to use, copy, modify, merge, publish, distribute, sublicense, and/or sell
+# copies of the Software, and to permit persons to whom the Software is
+# furnished to do so, subject to the following conditions:
+#
+# The above copyright notice and this permission notice shall be included in
+# all copies or substantial portions of the Software.
+#
+# THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
+# IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
+# FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
+# AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
+# LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
+# OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN
+# THE SOFTWARE.
+
+import unittest
+
+from factory.declarations import OrderedDeclaration, Sequence
+
+class OrderedDeclarationTestCase(unittest.TestCase):
+ def test_errors(self):
+ decl = OrderedDeclaration()
+ self.assertRaises(NotImplementedError, decl.evaluate, None, {})
+
+if __name__ == '__main__':
+ unittest.main()