diff options
author | Raphaël Barrois <raphael.barrois@polytechnique.org> | 2015-05-24 18:21:04 +0200 |
---|---|---|
committer | Raphaël Barrois <raphael.barrois@polytechnique.org> | 2015-05-24 18:21:04 +0200 |
commit | ebc89520d3f7589da35d4e7b78637fbe7d4d664a (patch) | |
tree | 99f2d3a171444ffcf2150b89bf2355a1f70036ff /setup.py | |
parent | 6f37f9be2d2e1bc75340068911db18b2bbcbe722 (diff) | |
download | factory-boy-ebc89520d3f7589da35d4e7b78637fbe7d4d664a.tar factory-boy-ebc89520d3f7589da35d4e7b78637fbe7d4d664a.tar.gz |
Add lazy loading to factory.Iterator.
factory.Iterator no longers begins iteration of its argument
on declaration, since this behavior may trigger database query
when that argument is, for instance, a Django queryset.
The ``factory.Iterator``'s argument will only be called when
the containing ``Factory`` is first evaluated; this means that
factories using ``factory.Iterator(models.MyThingy.objects.all())``
will no longer call the database at import time.
Diffstat (limited to 'setup.py')
-rwxr-xr-x | setup.py | 8 |
1 files changed, 4 insertions, 4 deletions
@@ -44,12 +44,12 @@ setup( keywords=['factory_boy', 'factory', 'fixtures'], packages=['factory'], license='MIT', - setup_requires=[ - 'setuptools>=0.8', - ], install_requires=[ 'fake-factory>=0.5.0', ], + setup_requires=[ + 'setuptools>=0.8', + ], tests_require=[ #'mock', ], @@ -69,7 +69,7 @@ setup( "Programming Language :: Python :: 3.4", "Programming Language :: Python :: Implementation :: PyPy", "Topic :: Software Development :: Testing", - "Topic :: Software Development :: Libraries :: Python Modules" + "Topic :: Software Development :: Libraries :: Python Modules", ], test_suite='tests', test_loader=test_loader, |