diff options
author | Raphaël Barrois <raphael.barrois@polytechnique.org> | 2011-12-21 01:01:59 +0100 |
---|---|---|
committer | Raphaël Barrois <raphael.barrois@polytechnique.org> | 2011-12-21 01:01:59 +0100 |
commit | 0cabe97af256c5b4ec72fc19a4ded7ac0f399c72 (patch) | |
tree | 30ff5fa01b698b7264d298812be3affd73210ef9 /setup.py | |
parent | 776674da04856635518d41de5375cea04f24d3d7 (diff) | |
download | factory-boy-0cabe97af256c5b4ec72fc19a4ded7ac0f399c72.tar factory-boy-0cabe97af256c5b4ec72fc19a4ded7ac0f399c72.tar.gz |
Add a 'test' command to the setup.py script.
Signed-off-by: Raphaël Barrois <raphael.barrois@polytechnique.org>
Diffstat (limited to 'setup.py')
-rw-r--r-- | setup.py | 34 |
1 files changed, 33 insertions, 1 deletions
@@ -2,10 +2,41 @@ # -*- coding: utf-8 -*- from distutils.core import setup +from distutils import cmd # Remember to change in factory/__init__.py as well! VERSION = '1.0.4' + +class test(cmd.Command): + """Run the tests for this package.""" + command_name = 'test' + description = 'run the tests associated with the package' + + user_options = [ + ('test-suite=', None, "A test suite to run (defaults to 'tests')"), + ] + + def initialize_options(self): + self.test_runner = None + self.test_suite = None + + def finalize_options(self): + self.ensure_string('test_suite', 'tests') + + def run(self): + """Run the test suite.""" + import unittest + if self.verbose: + verbosity=1 + else: + verbosity=0 + + suite = unittest.TestLoader().loadTestsFromName(self.test_suite) + + unittest.TextTestRunner(verbosity=verbosity).run(suite) + + setup( name='factory_boy_rbarrois', version=VERSION, @@ -25,5 +56,6 @@ setup( 'Programming Language :: Python', 'Topic :: Software Development :: Testing', 'Topic :: Software Development :: Libraries :: Python Modules' - ] + ], + cmdclass={'test': test}, ) |