diff options
author | Raphaël Barrois <raphael.barrois@polytechnique.org> | 2012-08-09 01:30:19 +0200 |
---|---|---|
committer | Raphaël Barrois <raphael.barrois@polytechnique.org> | 2012-08-09 01:30:19 +0200 |
commit | e0e628ec54b8a4d7f41f86f9f535d791a437b13c (patch) | |
tree | 1bc7a3f7546071afb6dd354d46eeb39c53c28f13 /setup.py | |
parent | f0d7e336f73a188405995b41aa30caaa78a01faa (diff) | |
download | factory-boy-e0e628ec54b8a4d7f41f86f9f535d791a437b13c.tar factory-boy-e0e628ec54b8a4d7f41f86f9f535d791a437b13c.tar.gz |
Better version computing code.
Signed-off-by: Raphaël Barrois <raphael.barrois@polytechnique.org>
Diffstat (limited to 'setup.py')
-rwxr-xr-x | setup.py | 18 |
1 files changed, 16 insertions, 2 deletions
@@ -1,12 +1,26 @@ #!/usr/bin/env python # -*- coding: utf-8 -*- +import os +import re import sys from distutils.core import setup from distutils import cmd -# Remember to change in factory/__init__.py as well! -VERSION = '1.1.5' +root = os.path.abspath(os.path.dirname(__file__)) + +def get_version(*module_dir_components): + version_re = re.compile(r"^__version__ = ['\"](.*)['\"]$") + module_root = os.path.join(root, *module_dir_components) + module_init = os.path.join(module_root, '__init__.py') + with open(module_init, 'r') as f: + for line in f: + match = version_re.match(line[:-1]) + if match: + return match.groups()[0] + return '0.1.0' + +VERSION = get_version('factory') class test(cmd.Command): |