diff options
author | Raphaël Barrois <raphael.barrois@polytechnique.org> | 2013-03-03 17:51:49 +0100 |
---|---|---|
committer | Raphaël Barrois <raphael.barrois@polytechnique.org> | 2013-03-03 21:38:46 +0100 |
commit | 050af55b77372b39fb6efecfb93bb6ee8ee425ed (patch) | |
tree | a9935cbe20f0482035526402b4f56cf68c735cf2 /setup.py | |
parent | 197e47a469b99595d992a51fbd48df0cd85532da (diff) | |
download | factory-boy-050af55b77372b39fb6efecfb93bb6ee8ee425ed.tar factory-boy-050af55b77372b39fb6efecfb93bb6ee8ee425ed.tar.gz |
Improve testing helpers.
Signed-off-by: Raphaël Barrois <raphael.barrois@polytechnique.org>
Diffstat (limited to 'setup.py')
-rwxr-xr-x | setup.py | 9 |
1 files changed, 8 insertions, 1 deletions
@@ -51,7 +51,14 @@ class test(cmd.Command): else: verbosity=0 - suite = unittest.TestLoader().loadTestsFromName(self.test_suite) + loader = unittest.TestLoader() + suite = unittest.TestSuite() + + if self.test_suite == 'tests': + for test_module in loader.discover('.'): + suite.addTest(test_module) + else: + suite.addTest(loader.loadTestsFromName(self.test_suite)) result = unittest.TextTestRunner(verbosity=verbosity).run(suite) if not result.wasSuccessful(): |