summaryrefslogtreecommitdiff
path: root/examples/Makefile
diff options
context:
space:
mode:
authorRaphaël Barrois <raphael.barrois@polytechnique.org>2015-07-15 23:15:13 +0200
committerRaphaël Barrois <raphael.barrois@polytechnique.org>2015-07-15 23:15:13 +0200
commitb0fbd24c69a155c4f9d58f5e4dab8209afeb3660 (patch)
tree7135e74933e7166563296023527aebf1122d4ea8 /examples/Makefile
parent63edb526bc4efd8cf7abe260f2787f55d2953e39 (diff)
downloadfactory-boy-b0fbd24c69a155c4f9d58f5e4dab8209afeb3660.tar
factory-boy-b0fbd24c69a155c4f9d58f5e4dab8209afeb3660.tar.gz
Add examples folder.
This should contain examples of "using factory_boy with third-party frameworks".
Diffstat (limited to 'examples/Makefile')
-rw-r--r--examples/Makefile9
1 files changed, 9 insertions, 0 deletions
diff --git a/examples/Makefile b/examples/Makefile
new file mode 100644
index 0000000..6064a9b
--- /dev/null
+++ b/examples/Makefile
@@ -0,0 +1,9 @@
+EXAMPLES = flask_alchemy
+
+TEST_TARGETS = $(addprefix runtest-,$(EXAMPLES))
+
+test: $(TEST_TARGETS)
+
+
+$(TEST_TARGETS): runtest-%:
+ cd $* && PYTHONPATH=../.. python -m unittest