summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorThomas Goirand <zigo@debian.org>2015-06-01 08:43:34 +0200
committerThomas Goirand <zigo@debian.org>2015-06-01 08:44:40 +0200
commitd92aeedcf27326270cb3dcd8b780566728a489a9 (patch)
treecc6a7711f351e05156c4acc484a80aac0c5f52a5 /debian
parentc8d021c5252b961aee4b777b61890189fd531e1c (diff)
downloadfactory-boy-d92aeedcf27326270cb3dcd8b780566728a489a9.tar
factory-boy-d92aeedcf27326270cb3dcd8b780566728a489a9.tar.gz
Fixed gbp.confdebian/2.4.1-4
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog1
-rw-r--r--debian/control2
-rw-r--r--debian/gbp.conf2
-rwxr-xr-xdebian/rules6
4 files changed, 6 insertions, 5 deletions
diff --git a/debian/changelog b/debian/changelog
index afa1207..0fc0258 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,6 +1,7 @@
factory-boy (2.4.1-4) unstable; urgency=medium
* Added Suggests: python-factory-boy-doc (Closes: #787282).
+ * Added dh-python build-depends.
-- Thomas Goirand <zigo@debian.org> Mon, 01 Jun 2015 08:39:54 +0200
diff --git a/debian/control b/debian/control
index 682d1c5..2086d84 100644
--- a/debian/control
+++ b/debian/control
@@ -17,9 +17,9 @@ Build-Depends-Indep: python-django,
python3-django,
python3-mock
Standards-Version: 3.9.6
-Homepage: https://github.com/rbarrois/factory_boy
Vcs-Browser: http://anonscm.debian.org/gitweb/?p=openstack/factory-boy.git;a=summary
Vcs-Git: git://anonscm.debian.org/openstack/factory-boy.git
+Homepage: https://github.com/rbarrois/factory_boy
Package: python-factory-boy
Architecture: all
diff --git a/debian/gbp.conf b/debian/gbp.conf
index ccf8702..7bf5959 100644
--- a/debian/gbp.conf
+++ b/debian/gbp.conf
@@ -4,5 +4,5 @@ debian-branch = debian/unstable
upstream-tag = %(version)s
compression = xz
-[git-buildpackage]
+[buildpackage]
export-dir = ../build-area/
diff --git a/debian/rules b/debian/rules
index 98463d9..613adf5 100755
--- a/debian/rules
+++ b/debian/rules
@@ -10,11 +10,11 @@ include /usr/share/openstack-pkg-tools/pkgos.make
dh $@ --buildsystem=python_distutils --with python2,python3,sphinxdoc
override_dh_auto_install:
- set -e && for pyvers in $(PYTHONS); do \
+ set -e ; for pyvers in $(PYTHONS); do \
python$$pyvers setup.py install --install-layout=deb \
--root $(CURDIR)/debian/python-factory-boy; \
done
- set -e && for pyvers in $(PYTHON3S); do \
+ set -e ; for pyvers in $(PYTHON3S); do \
python$$pyvers setup.py install --install-layout=deb \
--root $(CURDIR)/debian/python3-factory-boy; \
done
@@ -28,7 +28,7 @@ endif
override_dh_auto_test:
ifeq (,$(findstring nocheck, $(DEB_BUILD_OPTIONS)))
- set -e && for i in $(PYTHONS) $(PYTHON3S) ; do \
+ set -e ; for i in $(PYTHONS) $(PYTHON3S) ; do \
python$$i -W default setup.py test ; \
done
endif