summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorThomas Goirand <thomas@goirand.fr>2014-10-12 04:37:56 +0000
committerThomas Goirand <thomas@goirand.fr>2014-10-12 04:37:56 +0000
commitd34d35ee07712306d86fff68db5fe28dbe263ed6 (patch)
tree0c0225b8aa5442f9a8fbf53a0c7941acc8cf26ec /debian
parent6af6ed34537fa102ef5940b3cb095b5f23f13a9a (diff)
downloadfactory-boy-d34d35ee07712306d86fff68db5fe28dbe263ed6.tar
factory-boy-d34d35ee07712306d86fff68db5fe28dbe263ed6.tar.gz
* Add a patch to call django.setup() if using Django 1.7 in the unit tests.
This fixes FTBFS (Closes: #764837).
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog7
-rw-r--r--debian/patches/add-django-1.7-compat-with-new-django.setup.patch18
-rw-r--r--debian/patches/series1
3 files changed, 26 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog
index a1acdb5..6b0ea1c 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,10 @@
+factory-boy (2.4.1-3) unstable; urgency=medium
+
+ * Add a patch to call django.setup() if using Django 1.7 in the unit tests.
+ This fixes FTBFS (Closes: #764837).
+
+ -- Thomas Goirand <zigo@debian.org> Sun, 12 Oct 2014 04:36:54 +0000
+
factory-boy (2.4.1-2) unstable; urgency=medium
* Disabled broken a test (Closes: #759914).
diff --git a/debian/patches/add-django-1.7-compat-with-new-django.setup.patch b/debian/patches/add-django-1.7-compat-with-new-django.setup.patch
new file mode 100644
index 0000000..f2cf540
--- /dev/null
+++ b/debian/patches/add-django-1.7-compat-with-new-django.setup.patch
@@ -0,0 +1,18 @@
+Description: Make unit tests work with Django 1.7
+Author: Thomas Goirand <zigo@debian.org>
+Bug-Debian: https://bugs.debian.org/764837
+Forwarded: no
+Last-Update: 2014-10-12
+
+--- factory-boy-2.4.1.orig/tests/test_django.py
++++ factory-boy-2.4.1/tests/test_django.py
+@@ -50,6 +50,9 @@ from . import tools
+ if django is not None:
+ os.environ.setdefault('DJANGO_SETTINGS_MODULE', 'tests.djapp.settings')
+
++ if hasattr(django, 'setup'):
++ django.setup()
++
+ from django import test as django_test
+ from django.conf import settings
+ from django.db import models as django_models
diff --git a/debian/patches/series b/debian/patches/series
index 4a8b99a..b296b96 100644
--- a/debian/patches/series
+++ b/debian/patches/series
@@ -1,3 +1,4 @@
disable-intersphinx.patch
removed-privacy-breach.patch
disable-a-test-in-test_existing_file.patch
+add-django-1.7-compat-with-new-django.setup.patch