summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorThomas Goirand <thomas@goirand.fr>2012-10-14 12:11:24 +0000
committerThomas Goirand <thomas@goirand.fr>2012-10-14 12:12:52 +0000
commit1e12955d5f9a2edaf757db343b1bd3626566b440 (patch)
treeace418175953d28e93cbf10bb03032e6cd86e491 /debian
parentb54ff5c786dba08c5d35a0bc3e6dd1500c9fd7a0 (diff)
downloadfactory-boy-1e12955d5f9a2edaf757db343b1bd3626566b440.tar
factory-boy-1e12955d5f9a2edaf757db343b1bd3626566b440.tar.gz
* New upstream release.
* Added a get-vcs-source and debian/gbp.conf file. * Added everyone in the team as uploaders.
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog8
-rw-r--r--debian/control6
-rw-r--r--debian/gbp.conf8
-rwxr-xr-xdebian/rules20
4 files changed, 39 insertions, 3 deletions
diff --git a/debian/changelog b/debian/changelog
index d5d68fe..9593e28 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,11 @@
+factory-boy (1.1.5-1) experimental; urgency=low
+
+ * New upstream release.
+ * Added a get-vcs-source and debian/gbp.conf file.
+ * Added everyone in the team as uploaders.
+
+ -- Thomas Goirand <zigo@debian.org> Sun, 14 Oct 2012 12:06:03 +0000
+
factory-boy (1.1.3-1) unstable; urgency=low
* New upstream release
diff --git a/debian/control b/debian/control
index d65cb2d..c14716e 100644
--- a/debian/control
+++ b/debian/control
@@ -2,7 +2,11 @@ Source: factory-boy
Section: python
Priority: optional
Maintainer: PKG OpenStack <openstack-devel@lists.alioth.debian.org>
-Uploaders: Ghe Rivero <ghe.rivero@stackops.com>
+Uploaders: Loic Dachary (OuoU) <loic@debian.org>,
+ Julien Danjou <acid@debian.org>,
+ Thomas Goirand <zigo@debian.org>,
+ Ghe Rivero <ghe.rivero@stackops.com>,
+ Mehdi Abaakouk <sileht@sileht.net>
Build-Depends: debhelper (>= 7.0.50), python-dev (>=2.6.6-3~)
Standards-Version: 3.9.3
Homepage: https://github.com/rbarrois/factory_boy
diff --git a/debian/gbp.conf b/debian/gbp.conf
new file mode 100644
index 0000000..f9f4b78
--- /dev/null
+++ b/debian/gbp.conf
@@ -0,0 +1,8 @@
+[DEFAULT]
+upstream-branch = master
+debian-branch = debian/experimental
+upstream-tag = v%(version)s
+compression = xz
+
+[git-buildpackage]
+export-dir = ../build-area/
diff --git a/debian/rules b/debian/rules
index 206490c..8f89ae3 100755
--- a/debian/rules
+++ b/debian/rules
@@ -1,7 +1,23 @@
#!/usr/bin/make -f
-# Verbose mode
# export DH_VERBOSE=1
+DEBVERS := $(shell dpkg-parsechangelog | sed -n -e 's/^Version: //p')
+VERSION := $(shell echo '$(DEBVERS)' | sed -e 's/^[[:digit:]]*://' -e 's/[~-].*//')
+DEBFLAVOR :=$(shell dpkg-parsechangelog | grep -E ^Distribution: | cut -d" " -f2)
+DEBPKGNAME :=$(shell dpkg-parsechangelog | grep -E ^Source: | cut -d" " -f2)
+
%:
- dh $@ --with python2 \ No newline at end of file
+ dh $@ --with python2
+
+get-vcs-source:
+ git remote add upstream git://github.com/rbarrois/factory_boy.git || true
+ git fetch upstream
+ if [ ! -f ../$(DEBPKGNAME)_$(VERSION).orig.tar.xz ] ; then \
+ git archive --prefix=$(DEBPKGNAME)-$(VERSION)/ $(VERSION) | xz >../$(DEBPKGNAME)_$(VERSION).orig.tar.xz ; \
+ fi
+ if ! git checkout master ; then \
+ echo "No upstream branch: checking out" ; \
+ git checkout -b master upstream/master ; \
+ fi
+ git checkout debian/experimental