summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorThomas Goirand <thomas@goirand.fr>2014-05-04 00:55:51 +0800
committerThomas Goirand <thomas@goirand.fr>2014-05-04 00:55:51 +0800
commit5f99e831aa1b1fd06111f1e2ad23571b17ad4fcc (patch)
tree4e4a8a64986b8583c8cd998019fef65794ea1fcb /debian/rules
parent1eee818021ae83d8def921a23095fcc8d777c2f6 (diff)
downloadfactory-boy-5f99e831aa1b1fd06111f1e2ad23571b17ad4fcc.tar
factory-boy-5f99e831aa1b1fd06111f1e2ad23571b17ad4fcc.tar.gz
Now running unit tests at build time.
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules5
1 files changed, 5 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
index c450391..99dbc84 100755
--- a/debian/rules
+++ b/debian/rules
@@ -8,3 +8,8 @@ include /usr/share/openstack-pkg-tools/pkgos.make
%:
dh $@ --with python2 --buildsystem=python_distutils
+
+override_dh_auto_test:
+ifeq (,$(findstring nocheck, $(DEB_BUILD_OPTIONS)))
+ python -W default setup.py test
+endif