summaryrefslogtreecommitdiff
path: root/debian/control
diff options
context:
space:
mode:
authorThomas Goirand <thomas@goirand.fr>2014-07-03 15:24:19 +0800
committerThomas Goirand <thomas@goirand.fr>2014-07-03 15:43:25 +0800
commitd38fbe9fb1e61416038658f66402a9beb8c40629 (patch)
tree334db4b373c38a9133940a3cfd4aab089263abea /debian/control
parent943ad599d786fff3572b5173fa813f5a9a8c0195 (diff)
downloadfactory-boy-d38fbe9fb1e61416038658f66402a9beb8c40629.tar
factory-boy-d38fbe9fb1e61416038658f66402a9beb8c40629.tar.gz
Added Python3 support and sphinx doc.
Diffstat (limited to 'debian/control')
-rw-r--r--debian/control46
1 files changed, 43 insertions, 3 deletions
diff --git a/debian/control b/debian/control
index 32d7ab6..e599287 100644
--- a/debian/control
+++ b/debian/control
@@ -10,8 +10,15 @@ Uploaders: Loic Dachary (OuoU) <loic@debian.org>,
Build-Depends: debhelper (>= 9),
openstack-pkg-tools,
python-all (>=2.6.6-3~),
- python-setuptools
-Build-Depends-Indep: python-mock, python-unittest2
+ python-setuptools,
+ python-sphinx,
+ python3-all (>= 3.2),
+ python3-setuptools
+Build-Depends-Indep: python-django,
+ python-mock,
+ python-unittest2,
+ python3-django,
+ python3-mock
Standards-Version: 3.9.5
Homepage: https://github.com/rbarrois/factory_boy
Vcs-Browser: http://anonscm.debian.org/gitweb/?p=openstack/factory-boy.git;a=summary
@@ -21,7 +28,7 @@ Package: python-factory-boy
Architecture: all
Pre-Depends: dpkg (>= 1.15.6~)
Depends: ${misc:Depends}, ${python:Depends}, ${shlibs:Depends}
-Description: test fixtures replacement based on thoughtbot's factory_girl for Ruby
+Description: test fixtures replacement based on factory_girl for Ruby - Python 2.x
factory_boy is a fixtures replacement based on thoughtbot's factory_girl. Like
factory_girl it has a straightforward definition syntax, support for multiple
build strategies (saved instances, unsaved instances, attribute dicts, and
@@ -29,3 +36,36 @@ Description: test fixtures replacement based on thoughtbot's factory_girl for Ru
including factory inheritance.
.
Django support is included, and support for other ORMs can be easily added.
+ .
+ This package provides the Python 2.x module.
+
+Package: python3-factory-boy
+Architecture: all
+Pre-Depends: dpkg (>= 1.15.6~)
+Depends: ${misc:Depends}, ${python3:Depends}, ${shlibs:Depends}
+Description: test fixtures replacement based on factory_girl for Ruby - Python 3.x
+ factory_boy is a fixtures replacement based on thoughtbot's factory_girl. Like
+ factory_girl it has a straightforward definition syntax, support for multiple
+ build strategies (saved instances, unsaved instances, attribute dicts, and
+ stubbed objects), and support for multiple factories for the same class,
+ including factory inheritance.
+ .
+ Django support is included, and support for other ORMs can be easily added.
+ .
+ This package provides the Python 3.x module.
+
+Package: python-factory-boy-doc
+Section: doc
+Architecture: all
+Pre-Depends: dpkg (>= 1.15.6~)
+Depends: ${misc:Depends}, ${shlibs:Depends}, ${sphinxdoc:Depends}
+Description: test fixtures replacement based on factory_girl for Ruby - doc
+ factory_boy is a fixtures replacement based on thoughtbot's factory_girl. Like
+ factory_girl it has a straightforward definition syntax, support for multiple
+ build strategies (saved instances, unsaved instances, attribute dicts, and
+ stubbed objects), and support for multiple factories for the same class,
+ including factory inheritance.
+ .
+ Django support is included, and support for other ORMs can be easily added.
+ .
+ This package provides the documentation.