summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorRaphaël Barrois <raphael.barrois@polytechnique.org>2015-10-20 22:51:35 +0200
committerRaphaël Barrois <raphael.barrois@polytechnique.org>2015-10-20 22:53:45 +0200
commitb9347efae7e2f04687863f54e8db7d9e10f9dc6a (patch)
tree0e3d93bcf81731825799d127b31fa09237ece330 /Makefile
parent197555d3d0de4759ca9ad45d5986fdcc4aa4c15b (diff)
downloadfactory-boy-b9347efae7e2f04687863f54e8db7d9e10f9dc6a.tar
factory-boy-b9347efae7e2f04687863f54e8db7d9e10f9dc6a.tar.gz
examples: Fix make test (Closes #238)
Properly install dependencies from examples folders.
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile3
1 files changed, 2 insertions, 1 deletions
diff --git a/Makefile b/Makefile
index 79b5e82..35f635c 100644
--- a/Makefile
+++ b/Makefile
@@ -17,6 +17,7 @@ MONGOENGINE ?= 0.9
NEXT_MONGOENGINE = $(shell python -c "v='$(MONGOENGINE)'; parts=v.split('.'); parts[-1]=str(int(parts[-1])+1); print('.'.join(parts))")
REQ_FILE = auto_dev_requirements_django$(DJANGO)_alchemy$(ALCHEMY)_mongoengine$(MONGOENGINE).txt
+EXAMPLES_REQ_FILES = $(shell find $(EXAMPLES_DIR) -name requirements.txt)
all: default
@@ -29,7 +30,7 @@ install-deps: $(REQ_FILE)
pip install --upgrade -r $<
pip freeze
-$(REQ_FILE): dev_requirements.txt requirements.txt
+$(REQ_FILE): dev_requirements.txt requirements.txt $(EXAMPLES_REQ_FILES)
grep --no-filename "^[^#-]" $^ | egrep -v "^(Django|SQLAlchemy|mongoengine)" > $@
echo "Django>=$(DJANGO),<$(NEXT_DJANGO)" >> $@
echo "SQLAlchemy>=$(ALCHEMY),<$(NEXT_ALCHEMY)" >> $@