summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorRaphaël Barrois <raphael.barrois@polytechnique.org>2013-06-15 16:15:39 +0200
committerRaphaël Barrois <raphael.barrois@polytechnique.org>2013-06-15 16:17:14 +0200
commitb72fa40e52f3b767144b11f1d83c36d417f023d8 (patch)
tree4233f832395b2ee9a5bb3034b55dd404f4371d61 /Makefile
parent94d7defa820b69152fb5aeadb3f5ccc3611158fa (diff)
downloadfactory-boy-b72fa40e52f3b767144b11f1d83c36d417f023d8.tar
factory-boy-b72fa40e52f3b767144b11f1d83c36d417f023d8.tar.gz
Fix coverage
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile10
1 files changed, 6 insertions, 4 deletions
diff --git a/Makefile b/Makefile
index 274ee32..6e798c9 100644
--- a/Makefile
+++ b/Makefile
@@ -2,6 +2,8 @@ PACKAGE=factory
TESTS_DIR=tests
DOC_DIR=docs
+# Use current python binary instead of system default.
+COVERAGE = python $(shell which coverage)
all: default
@@ -20,10 +22,10 @@ pylint:
pylint --rcfile=.pylintrc --report=no $(PACKAGE)/
coverage:
- coverage erase
- coverage run "--include=$(PACKAGE)/*.py,$(TESTS_DIR)/*.py" --branch setup.py test
- coverage report "--include=$(PACKAGE)/*.py,$(TESTS_DIR)/*.py"
- coverage html "--include=$(PACKAGE)/*.py,$(TESTS_DIR)/*.py"
+ $(COVERAGE) erase
+ $(COVERAGE) run "--include=$(PACKAGE)/*.py,$(TESTS_DIR)/*.py" --branch setup.py test
+ $(COVERAGE) report "--include=$(PACKAGE)/*.py,$(TESTS_DIR)/*.py"
+ $(COVERAGE) html "--include=$(PACKAGE)/*.py,$(TESTS_DIR)/*.py"
doc:
$(MAKE) -C $(DOC_DIR) html