summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorRaphaël Barrois <raphael.barrois@polytechnique.org>2015-07-15 23:15:13 +0200
committerRaphaël Barrois <raphael.barrois@polytechnique.org>2015-07-15 23:15:13 +0200
commitb0fbd24c69a155c4f9d58f5e4dab8209afeb3660 (patch)
tree7135e74933e7166563296023527aebf1122d4ea8 /Makefile
parent63edb526bc4efd8cf7abe260f2787f55d2953e39 (diff)
downloadfactory-boy-b0fbd24c69a155c4f9d58f5e4dab8209afeb3660.tar
factory-boy-b0fbd24c69a155c4f9d58f5e4dab8209afeb3660.tar.gz
Add examples folder.
This should contain examples of "using factory_boy with third-party frameworks".
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile6
1 files changed, 5 insertions, 1 deletions
diff --git a/Makefile b/Makefile
index 8883015..79b5e82 100644
--- a/Makefile
+++ b/Makefile
@@ -1,6 +1,7 @@
PACKAGE=factory
TESTS_DIR=tests
DOC_DIR=docs
+EXAMPLES_DIR=examples
# Use current python binary instead of system default.
COVERAGE = python $(shell which coverage)
@@ -43,9 +44,12 @@ clean:
@rm -rf tmp_test/
-test: install-deps
+test: install-deps example-test
python -W default setup.py test
+example-test:
+ $(MAKE) -C $(EXAMPLES_DIR) test
+
pylint:
pylint --rcfile=.pylintrc --report=no $(PACKAGE)/