summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorRaphaël Barrois <raphael.barrois@polytechnique.org>2013-04-03 01:17:26 +0200
committerRaphaël Barrois <raphael.barrois@polytechnique.org>2013-04-03 01:19:45 +0200
commit8c1784e8c1eac65f66b4a1ecc4b8b0ddd5de9327 (patch)
tree0b1d368f114de4235dc3d88e2dfc41b3403d16ef /Makefile
parent3aee208ee7cdf480cbc173cf3084ce2217a5944f (diff)
downloadfactory-boy-8c1784e8c1eac65f66b4a1ecc4b8b0ddd5de9327.tar
factory-boy-8c1784e8c1eac65f66b4a1ecc4b8b0ddd5de9327.tar.gz
Pylint.
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile18
1 files changed, 13 insertions, 5 deletions
diff --git a/Makefile b/Makefile
index f9c27c0..274ee32 100644
--- a/Makefile
+++ b/Makefile
@@ -1,3 +1,8 @@
+PACKAGE=factory
+TESTS_DIR=tests
+DOC_DIR=docs
+
+
all: default
@@ -11,14 +16,17 @@ clean:
test:
python -W default setup.py test
+pylint:
+ pylint --rcfile=.pylintrc --report=no $(PACKAGE)/
+
coverage:
coverage erase
- coverage run "--include=factory/*.py,tests/*.py" --branch setup.py test
- coverage report "--include=factory/*.py,tests/*.py"
- coverage html "--include=factory/*.py,tests/*.py"
+ coverage run "--include=$(PACKAGE)/*.py,$(TESTS_DIR)/*.py" --branch setup.py test
+ coverage report "--include=$(PACKAGE)/*.py,$(TESTS_DIR)/*.py"
+ coverage html "--include=$(PACKAGE)/*.py,$(TESTS_DIR)/*.py"
doc:
- $(MAKE) -C docs html
+ $(MAKE) -C $(DOC_DIR) html
-.PHONY: all default clean coverage doc test
+.PHONY: all default clean coverage doc pylint test