summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRaphaël Barrois <raphael.barrois@polyconseil.fr>2015-04-27 16:39:10 +0200
committerRaphaël Barrois <raphael.barrois@polyconseil.fr>2015-04-27 16:39:41 +0200
commit29de94f46b356bef181e8cf02d6cb3ae4ac52075 (patch)
tree011e8c125a82ec7a486cff63899c0fc665c0a2e8
parente95475d492ea4e08ebc9b99e1851861df1eb83c0 (diff)
downloadfactory-boy-29de94f46b356bef181e8cf02d6cb3ae4ac52075.tar
factory-boy-29de94f46b356bef181e8cf02d6cb3ae4ac52075.tar.gz
Allow skipping Mongo tests.
-rw-r--r--.travis.yml2
-rw-r--r--tests/test_mongoengine.py3
2 files changed, 4 insertions, 1 deletions
diff --git a/.travis.yml b/.travis.yml
index ed331d4..e1600bd 100644
--- a/.travis.yml
+++ b/.travis.yml
@@ -6,7 +6,7 @@ python:
- "pypy"
script:
- - python setup.py test
+ - SKIP_MONGOENGINE=1 python setup.py test
install:
- make install-deps
diff --git a/tests/test_mongoengine.py b/tests/test_mongoengine.py
index 6fa4125..7badd43 100644
--- a/tests/test_mongoengine.py
+++ b/tests/test_mongoengine.py
@@ -31,6 +31,9 @@ try:
except ImportError:
mongoengine = None
+if os.environ.get('SKIP_MONGOENGINE') == 1:
+ mongoengine = None
+
if mongoengine:
from factory.mongoengine import MongoEngineFactory