summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRaphaël Barrois <raphael.barrois@polytechnique.org>2015-04-19 17:00:53 +0200
committerRaphaël Barrois <raphael.barrois@polytechnique.org>2015-04-19 17:00:53 +0200
commit23616f4a376f79aaf0f9088dc15dc87a668e1ef2 (patch)
treea6c1af3486190f0adb6e2aa0a909a45aa0b0d646
parent52c984d3f1c6c440a832e53331d7f95f25c8b046 (diff)
downloadfactory-boy-23616f4a376f79aaf0f9088dc15dc87a668e1ef2.tar
factory-boy-23616f4a376f79aaf0f9088dc15dc87a668e1ef2.tar.gz
Update travis config: focus on Py2.7/Py3.4
-rw-r--r--.travis.yml7
1 files changed, 2 insertions, 5 deletions
diff --git a/.travis.yml b/.travis.yml
index 3954bf5..a1d14f6 100644
--- a/.travis.yml
+++ b/.travis.yml
@@ -1,18 +1,15 @@
language: python
python:
- - "2.6"
- "2.7"
- - "3.2"
- - "3.3"
+ - "3.4"
- "pypy"
script:
- python setup.py test
install:
- - if [[ $TRAVIS_PYTHON_VERSION = 2.6 ]]; then pip install unittest2 --use-mirrors; fi
- - if [[ $TRAVIS_PYTHON_VERSION = 2.6 ]]; then pip install "Django<1.7" --use-mirrors; else pip install Django; fi
+ - pip install Django
- pip install sqlalchemy --use-mirrors
- if ! python --version 2>&1 | grep -q -i pypy ; then pip install Pillow --use-mirrors; fi