summaryrefslogtreecommitdiff
path: root/.travis.yml
diff options
context:
space:
mode:
authornkryptic <nkryptic@gmail.com>2013-03-12 01:08:59 -0400
committerRaphaël Barrois <raphael.barrois@polytechnique.org>2013-03-15 01:58:46 +0100
commit6c4f5846c8e21d6e48347b7e661edb72ffabb9f1 (patch)
tree966472532d500451f11a6e63ba27daa1d4d03aeb /.travis.yml
parent624aedf03974bedb34349d0664fb863935e99969 (diff)
downloadfactory-boy-6c4f5846c8e21d6e48347b7e661edb72ffabb9f1.tar
factory-boy-6c4f5846c8e21d6e48347b7e661edb72ffabb9f1.tar.gz
Add full Python 3 compatibility (Closes #10, #20, #49).
Also: - update travis.yml to build against 2.6-2.7 and 3.2-3.3 - Switch to relative imports Signed-off-by: Raphaël Barrois <raphael.barrois@polytechnique.org>
Diffstat (limited to '.travis.yml')
-rw-r--r--.travis.yml12
1 files changed, 10 insertions, 2 deletions
diff --git a/.travis.yml b/.travis.yml
index aa990e6..e32214b 100644
--- a/.travis.yml
+++ b/.travis.yml
@@ -1,9 +1,17 @@
language: python
+
python:
- "2.6"
- "2.7"
-script: "python setup.py test"
-install: "if [[ $TRAVIS_PYTHON_VERSION = 2.6 ]]; then pip install unittest2 --use-mirrors; fi"
+ - "3.2"
+ - "3.3"
+
+script:
+ - python setup.py test
+
+install:
+ - "if [[ $TRAVIS_PYTHON_VERSION = 2.6 ]]; then pip install unittest2 --use-mirrors; fi"
+
notifications:
email: false
irc: "irc.freenode.org#factory_boy"