summaryrefslogtreecommitdiff
path: root/gnu/packages/cran.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/cran.scm')
-rw-r--r--gnu/packages/cran.scm31
1 files changed, 30 insertions, 1 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index e8b635ac16..cd2fea5996 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -12306,6 +12306,8 @@ select colors to use in your R code.")
("r-scales" ,r-scales)
("r-shiny" ,r-shiny)
("r-shinyjs" ,r-shinyjs)))
+ (native-inputs
+ `(("r-knitr" ,r-knitr)))
(home-page "https://github.com/daattali/ggExtra")
(synopsis "Marginal histograms for ggplot2 and other enhancements")
(description
@@ -18006,6 +18008,8 @@ allowed.")
("r-rsolnp" ,r-rsolnp)
("r-shiny" ,r-shiny)
("r-shinydashboard" ,r-shinydashboard)))
+ (native-inputs
+ `(("r-knitr" ,r-knitr)))
(home-page "https://github.com/Wenchao-Ma/GDINA")
(synopsis "Generalized DINA model framework")
(description
@@ -20620,7 +20624,7 @@ techniques to average Bayesian predictive distributions.")
"/share/zoneinfo"))
#t)))))
(native-inputs
- `(("tzdata" ,tzdata)
+ `(("tzdata" ,tzdata-for-tests)
("pandoc" ,ghc-pandoc)))
(propagated-inputs
`(("r-bh" ,r-bh)
@@ -21102,3 +21106,28 @@ client).")
designs with and without early outcomes for treatment selection and
subpopulation type designs.")
(license license:gpl3)))
+
+(define-public r-nbconvertr
+ (package
+ (name "r-nbconvertr")
+ (version "1.3.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "nbconvertR" version))
+ (sha256
+ (base32
+ "0yhmz177r1miain65vspclahhz8cg7638ldbpsw8ylgf7a60l0sg"))))
+ (properties `((upstream-name . "nbconvertR")))
+ (build-system r-build-system)
+ (inputs
+ `(("jupyter" ,python-nbconvert)
+ ("pandoc" ,ghc-pandoc)))
+ (home-page "https://cran.r-project.org/web/packages/nbconvertR/")
+ (synopsis "Vignette engine wrapping Jupyter notebooks")
+ (description
+ "This package calls the Jupyter script @code{nbconvert} to create
+vignettes from notebooks. Those notebooks (@code{.ipynb} files) are files
+containing rich text, code, and its output. Code cells can be edited and
+evaluated interactively.")
+ (license license:gpl3)))