summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2020-02-07 23:26:38 +0100
committerLudovic Courtès <ludo@gnu.org>2020-02-12 20:35:43 +0100
commitfd1fde6041b7f221bed114593944365d21cb925c (patch)
tree1c43aadc982bd036083edabf9c8b0d7d91525762
parentf30d84d32db0f4f6cb84e139868e1727a7dc0a51 (diff)
downloadpatches-fd1fde6041b7f221bed114593944365d21cb925c.tar
patches-fd1fde6041b7f221bed114593944365d21cb925c.tar.gz
gnu: rust: Switch to 'C_INCLUDE_PATH'.
* gnu/packages/rust.scm (rust-1.19)[native-search-paths]: Remove "CPATH" and add "C_INCLUDE_PATH" and "CPLUS_INCLUDE_PATH" instead.
-rw-r--r--gnu/packages/rust.scm5
1 files changed, 4 insertions, 1 deletions
diff --git a/gnu/packages/rust.scm b/gnu/packages/rust.scm
index 8bed56ff72..97ba882553 100644
--- a/gnu/packages/rust.scm
+++ b/gnu/packages/rust.scm
@@ -413,9 +413,12 @@ test = { path = \"../libtest\" }
;; modules (see <https://bugs.gnu.org/31392>).
(native-search-paths
(list (search-path-specification
- (variable "CPATH")
+ (variable "C_INCLUDE_PATH")
(files '("include")))
(search-path-specification
+ (variable "CPLUS_INCLUDE_PATH")
+ (files '("include/c++" "include")))
+ (search-path-specification
(variable "LIBRARY_PATH")
(files '("lib" "lib64")))))