summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEric Bavier <bavier@cray.com>2018-08-29 14:12:58 -0500
committerEric Bavier <bavier@member.fsf.org>2018-08-30 00:44:40 -0500
commitf9e140a243b6d6b5d28bd0813b69604562a39653 (patch)
treec5384286bd993db9addb0077656a2012c56d0727
parentc558113fb9ac60b8ec9ffca6f8059518514c548c (diff)
downloadpatches-f9e140a243b6d6b5d28bd0813b69604562a39653.tar
patches-f9e140a243b6d6b5d28bd0813b69604562a39653.tar.gz
netsurf: Upgrade to 3.8.
* gnu/packages/patches/netsurf-message-timestamp.patch: New patch. * gnu/packages/patches/netsurf-system-utf8proc.patch: Adjust to new source. * gnu/packages/web.scm (netsurf): Upgrade to 3.8. [source]: Add the new patch.
-rw-r--r--gnu/packages/patches/netsurf-message-timestamp.patch11
-rw-r--r--gnu/packages/patches/netsurf-system-utf8proc.patch25
-rw-r--r--gnu/packages/web.scm7
3 files changed, 28 insertions, 15 deletions
diff --git a/gnu/packages/patches/netsurf-message-timestamp.patch b/gnu/packages/patches/netsurf-message-timestamp.patch
new file mode 100644
index 0000000000..8df9dbf8f7
--- /dev/null
+++ b/gnu/packages/patches/netsurf-message-timestamp.patch
@@ -0,0 +1,11 @@
+--- netsurf-3.8/utils/split-messages.pl.orig 1969-12-31 18:00:00.000000000 -0600
++++ netsurf-3.8/utils/split-messages.pl 2018-08-30 00:18:58.158367530 -0500
+@@ -238,7 +238,7 @@
+
+ if( $opt{gzip} )
+ {
+- $ofh = new IO::Compress::Gzip( $ofh, AutoClose => 1, -Level => 9 );
++ $ofh = new IO::Compress::Gzip( $ofh, AutoClose => 1, -Level => 9, Time => 0 );
+ }
+
+ return $ofh;
diff --git a/gnu/packages/patches/netsurf-system-utf8proc.patch b/gnu/packages/patches/netsurf-system-utf8proc.patch
index 654d45d017..a2ee52ca05 100644
--- a/gnu/packages/patches/netsurf-system-utf8proc.patch
+++ b/gnu/packages/patches/netsurf-system-utf8proc.patch
@@ -17,23 +17,23 @@ Work around upstream's lack of a pkg-config file and update API.
# Optional libraries with pkgconfig
---- netsurf-3.6/utils/idna.c
-+++ netsurf-3.6/utils/idna.c
-@@ -26,7 +26,7 @@
- #include <stdint.h>
+--- netsurf-3.8/utils/idna.c
++++ netsurf-3.8/utils/idna.c
+@@ -27,7 +27,7 @@
#include <stdlib.h>
#include <string.h>
+ #include <sys/types.h>
-#include <libutf8proc/utf8proc.h>
+#include <utf8proc.h>
- #include "utils/errors.h"
- #include "utils/idna.h"
---- netsurf-3.7/test/Makefile 2017-10-15 08:39:24.000000000 -0500
-+++ netsurf-3.7/test/Makefile 2017-11-05 11:14:46.219013218 -0600
-@@ -139,14 +139,14 @@
- -D_XOPEN_SOURCE=600 \
+ #include "netsurf/inttypes.h"
+
+--- netsurf-3.8/test/Makefile
++++ netsurf-3.8/test/Makefile
+@@ -142,14 +142,15 @@
-Itest -Iinclude -Icontent/handlers -Ifrontends -I. -I.. \
-Dnsgtk \
+ $(SAN_FLAGS) \
- $(shell pkg-config --cflags libcurl libparserutils libwapcaplet libdom libnsutils libutf8proc) \
+ $(shell pkg-config --cflags libcurl libparserutils libwapcaplet libdom libnsutils) \
$(LIB_CFLAGS)
@@ -43,7 +43,8 @@ Work around upstream's lack of a pkg-config file and update API.
TESTLDFLAGS := -L$(TESTROOT) \
- $(shell pkg-config --libs libcurl libparserutils libwapcaplet libdom libnsutils libutf8proc) -lz \
-+ $(shell pkg-config --libs libcurl libparserutils libwapcaplet libdom libnsutils) -lz -lutf8proc \
++ $(shell pkg-config --libs libcurl libparserutils libwapcaplet libdom libnsutils) \
++ $(LDFLAGS) \
+ $(SAN_FLAGS) \
$(LIB_LDFLAGS)\
$(COV_LDFLAGS)
-
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index 6fc917b6be..0d27fa0054 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -4694,7 +4694,7 @@ w3c webidl files and a binding configuration file.")
(define-public netsurf
(package
(name "netsurf")
- (version "3.7")
+ (version "3.8")
(source
(origin
(method url-fetch)
@@ -4702,10 +4702,11 @@ w3c webidl files and a binding configuration file.")
"releases/source/netsurf-" version "-src.tar.gz"))
(sha256
(base32
- "05kynfzzwd4fc03vbqdjpghh5xnk2yrh43w7vikak89vla30mhpg"))
+ "0hjm1h4m1i913y4mhkl7yqdifn8k70fwi58zdh6faypawzryc3m0"))
(patches (search-patches "netsurf-system-utf8proc.patch"
"netsurf-y2038-tests.patch"
- "netsurf-longer-test-timeout.patch"))))
+ "netsurf-longer-test-timeout.patch"
+ "netsurf-message-timestamp.patch"))))
(build-system glib-or-gtk-build-system)
(native-inputs
`(("netsurf-buildsystem" ,netsurf-buildsystem)