summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrendan Tildesley <mail@brendan.scot>2019-05-04 02:42:21 +1000
committerDanny Milosavljevic <dannym@scratchpost.org>2019-05-05 14:44:20 +0200
commitf89f5abada5dce72a6b40b2310bc9b5b97a6f1a9 (patch)
treeb04a16706025df38b5727169df30fe442c7b06a9
parent6e1ab5fadbc8fbe5d8d71864c68dd52ddbc732c9 (diff)
downloadpatches-f89f5abada5dce72a6b40b2310bc9b5b97a6f1a9.tar
patches-f89f5abada5dce72a6b40b2310bc9b5b97a6f1a9.tar.gz
gnu: calibre: Disable bs4 test.
* gnu/packages/patches/calibre-remove-test-bs4.patch: New file. * gnu/packages/ebook.scm (calibre)[source]: Use it. * gnu/local.mk (dist_patch_DATA): Add it. Signed-off-by: Danny Milosavljevic <dannym@scratchpost.org>
-rw-r--r--gnu/local.mk1
-rw-r--r--gnu/packages/ebook.scm1
-rw-r--r--gnu/packages/patches/calibre-remove-test-bs4.patch34
3 files changed, 36 insertions, 0 deletions
diff --git a/gnu/local.mk b/gnu/local.mk
index d5b7a2c5e5..9e31868281 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -690,6 +690,7 @@ dist_patch_DATA = \
%D%/packages/patches/boost-fix-icu-build.patch \
%D%/packages/patches/byobu-writable-status.patch \
%D%/packages/patches/calibre-no-updates-dialog.patch \
+ %D%/packages/patches/calibre-remove-test-bs4.patch \
%D%/packages/patches/calibre-remove-test-unrar.patch \
%D%/packages/patches/casync-renameat2-declaration.patch \
%D%/packages/patches/catdoc-CVE-2017-11110.patch \
diff --git a/gnu/packages/ebook.scm b/gnu/packages/ebook.scm
index 964fdd7b75..b5f8283996 100644
--- a/gnu/packages/ebook.scm
+++ b/gnu/packages/ebook.scm
@@ -97,6 +97,7 @@
(delete-file "src/odf/thumbnail.py")
#t))
(patches (search-patches "calibre-no-updates-dialog.patch"
+ "calibre-remove-test-bs4.patch" ; TODO: fix test.
"calibre-remove-test-unrar.patch"))))
(build-system python-build-system)
(native-inputs
diff --git a/gnu/packages/patches/calibre-remove-test-bs4.patch b/gnu/packages/patches/calibre-remove-test-bs4.patch
new file mode 100644
index 0000000000..77dd45d329
--- /dev/null
+++ b/gnu/packages/patches/calibre-remove-test-bs4.patch
@@ -0,0 +1,34 @@
+In my efforts to fix all Calibre tests, this test would always complain about
+backports.functools_lru_cache not existing even after I packaged and added
+python2-soupsieve as an input and confirmed it was in the
+PYTHONPATH. Currently Calibre does not actually use it for anything other than
+testing it's there, so I assume they will start using it in future Calibre
+versions.
+
+From 2738dd42caebe55326c76922a12ba8740bdb22e7 Mon Sep 17 00:00:00 2001
+From: Brendan Tildesley <mail@brendan.scot>
+Date: Sat, 27 Apr 2019 00:42:39 +1000
+Subject: [PATCH] Remove test_bs4
+
+---
+ src/calibre/test_build.py | 4 ----
+ 1 file changed, 4 deletions(-)
+
+diff --git a/src/calibre/test_build.py b/src/calibre/test_build.py
+index 73f1172e8c..07bdffd3e5 100644
+--- a/src/calibre/test_build.py
++++ b/src/calibre/test_build.py
+@@ -73,10 +73,6 @@ class BuildTest(unittest.TestCase):
+ from html5_parser import parse
+ parse('<p>xxx')
+
+- def test_bs4(self):
+- import soupsieve, bs4
+- del soupsieve, bs4
+-
+ def test_zeroconf(self):
+ if ispy3:
+ import zeroconf as z, ifaddr
+--
+2.21.0
+