summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2015-06-02 15:41:37 -0400
committerMark H Weaver <mhw@netris.org>2015-06-02 15:43:34 -0400
commited8a724b331869bf79a441a8c2243d2c4468101d (patch)
treefe39b60334d2bf677d860f393f59afdd7348a924
parent9a59ce2455de064821274bcfa2ad660c6ae6da05 (diff)
downloadpatches-ed8a724b331869bf79a441a8c2243d2c4468101d.tar
patches-ed8a724b331869bf79a441a8c2243d2c4468101d.tar.gz
gnu: gnu-pw-mgr: Update to 1.4.
* gnu/packages/gnu-pw-mgr.scm (gnu-pw-mgr): Update to 1.4. Use .xz tarball. Move 'which' to native-inputs. Add 'autogen' to native-inputs.
-rw-r--r--gnu/packages/gnu-pw-mgr.scm13
1 files changed, 8 insertions, 5 deletions
diff --git a/gnu/packages/gnu-pw-mgr.scm b/gnu/packages/gnu-pw-mgr.scm
index e0f223d7d6..7a9b0b9810 100644
--- a/gnu/packages/gnu-pw-mgr.scm
+++ b/gnu/packages/gnu-pw-mgr.scm
@@ -23,22 +23,25 @@
#:use-module (guix download)
#:use-module (guix build-system gnu)
#:use-module (gnu packages)
- #:use-module (gnu packages base))
+ #:use-module (gnu packages base)
+ #:use-module (gnu packages autogen))
(define-public gnu-pw-mgr
(package
(name "gnu-pw-mgr")
- (version "1.3")
+ (version "1.4")
(source
(origin
(method url-fetch)
(uri (string-append "mirror://gnu/gnu-pw-mgr/gnu-pw-mgr-"
- version ".tar.gz"))
+ version ".tar.xz"))
(sha256
(base32
- "0rbnv5wszpr35py97vwylqkdlf06qpd2x9j9aqlmgkd4mr1n4hf0"))))
+ "0a352y1m33vp6zmdbn96fdrq9gr9lchc9vcrj14mfx7g0dsvxjns"))))
(build-system gnu-build-system)
- (inputs `(("which" ,which)))
+ (native-inputs
+ `(("which" ,which)
+ ("autogen" ,autogen)))
(home-page "http://www.gnu.org/software/gnu-pw-mgr/")
(synopsis "Retrieve login credentials without recording passwords")
(description