summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars-Dominik Braun <ldb@leibniz-psychology.org>2020-03-27 13:55:03 +0100
committerLudovic Courtès <ludo@gnu.org>2020-04-02 00:06:26 +0200
commitecceef27c8913654714b091243263b9e590e3f8a (patch)
tree18c0eb2bf740ea7753ef81b6842989223798ded8
parent4b75a7060058bc2e959dcb4145067f6bba3e34e5 (diff)
downloadpatches-ecceef27c8913654714b091243263b9e590e3f8a.tar
patches-ecceef27c8913654714b091243263b9e590e3f8a.tar.gz
gnu: gunicorn: Update to 20.0.4
* gnu/packages/python-web.scm (gunicorn) [version]: Update to 20.0.4 [arguments] Re-enable previously failing tests Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/python-web.scm9
1 files changed, 2 insertions, 7 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 26e2fe04ec..19c08026f2 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -3390,14 +3390,14 @@ hard or impossible to fix in cssselect.")
(define-public gunicorn
(package
(name "gunicorn")
- (version "20.0.0")
+ (version "20.0.4")
(source
(origin
(method url-fetch)
(uri (pypi-uri "gunicorn" version))
(sha256
(base32
- "0l1zm8a0vz8ws3lkn8q9a0f93ipdzyvlf2zlwdj5xyadh6jdwsgg"))))
+ "09n6fc019bgrvph1s5h1lwhn2avcsprw6ncd203qhra3i8mvn10r"))))
(outputs '("out" "doc"))
(build-system python-build-system)
(arguments
@@ -3413,11 +3413,6 @@ hard or impossible to fix in cssselect.")
(lambda _
(setenv "PYTHONPATH"
(string-append ".:" (getenv "PYTHONPATH")))
- ;; Remove test modules failing due to libc not found due to
- ;; section '.dynamic' not found in libc.so
- (delete-file "tests/test_arbiter.py")
- (delete-file "tests/test_config.py")
- (delete-file "tests/test_sock.py")
(invoke "pytest")))
(add-after 'install 'install-doc
(lambda* (#:key outputs #:allow-other-keys)