summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2015-09-25 17:02:13 +0200
committerLudovic Courtès <ludo@gnu.org>2015-09-25 17:02:13 +0200
commite2aace769c878115d9fe697af4ce87fe7ff75d14 (patch)
treef0aaea47f2d5c8767a621fa642c6c08258504afa
parentc3aeac385aba64996c8470975fea853030d1cc3a (diff)
downloadpatches-e2aace769c878115d9fe697af4ce87fe7ff75d14.tar
patches-e2aace769c878115d9fe697af4ce87fe7ff75d14.tar.gz
gnu: glibc-locales: Update to glibc 2.22.
* gnu/packages/base.scm (glibc-locales)[arguments]: Remove 'delete-file-recursively' call from 'build' phase. * gnu/packages/patches/glibc-locales.patch: Adjust to glibc 2.22.
-rw-r--r--gnu/packages/base.scm4
-rw-r--r--gnu/packages/patches/glibc-locales.patch14
2 files changed, 7 insertions, 11 deletions
diff --git a/gnu/packages/base.scm b/gnu/packages/base.scm
index 69db178e05..a3e3e36608 100644
--- a/gnu/packages/base.scm
+++ b/gnu/packages/base.scm
@@ -640,10 +640,6 @@ the 'share/locale' sub-directory of this package.")
`(alist-replace
'build
(lambda* (#:key outputs #:allow-other-keys)
- (let ((out (assoc-ref outputs "out")))
- ;; Delete $out/bin, which contains 'bash'.
- (delete-file-recursively (string-append out "/bin")))
-
(zero? (system* "make" "localedata/install-locales"
"-j" (number->string (parallel-job-count)))))
(alist-delete 'install ,phases)))
diff --git a/gnu/packages/patches/glibc-locales.patch b/gnu/packages/patches/glibc-locales.patch
index 1d254e1c1d..1bcf12bf6f 100644
--- a/gnu/packages/patches/glibc-locales.patch
+++ b/gnu/packages/patches/glibc-locales.patch
@@ -9,9 +9,9 @@ in a package separate from glibc.
because otherwise, 'localedef' fails with:
"cannot write output files to `(null)'".
---- glibc-2.20/localedata/Makefile 2014-09-07 10:09:09.000000000 +0200
-+++ glibc-2.20/localedata/Makefile 2015-02-11 10:23:55.560545568 +0100
-@@ -217,7 +217,7 @@ INSTALL-SUPPORTED-LOCALES=$(addprefix in
+--- glibc-2.22/localedata/Makefile 1970-01-01 01:00:00.000000000 +0100
++++ glibc-2.22/localedata/Makefile 2015-09-25 14:18:34.698941752 +0200
+@@ -195,7 +195,7 @@ INSTALL-SUPPORTED-LOCALES=$(addprefix in
# Sometimes the whole collection of locale files should be installed.
LOCALEDEF=I18NPATH=. GCONV_PATH=$(common-objpfx)iconvdata LC_ALL=C \
@@ -20,12 +20,12 @@ in a package separate from glibc.
install-locales: $(INSTALL-SUPPORTED-LOCALES)
install-locales-dir:
-@@ -234,7 +234,7 @@ $(INSTALL-SUPPORTED-LOCALES): install-lo
+@@ -212,7 +212,7 @@ $(INSTALL-SUPPORTED-LOCALES): install-lo
input=`echo $$locale | sed 's/\([^.]*\)[^@]*\(.*\)/\1\2/'`; \
$(LOCALEDEF) --alias-file=../intl/locale.alias \
-i locales/$$input -c -f charmaps/$$charset \
-- $(addprefix --prefix=,$(install_root)) $$locale; \
-+ $(addprefix --prefix=,$(install_root)) $(localedir)/$$locale; \
- echo ' done'; \
+- $(addprefix --prefix=,$(install_root)) $$locale \
++ $(addprefix --prefix=,$(install_root)) $(localedir)/$$locale \
+ && echo ' done'; \
tst-setlocale-ENV = LC_ALL=ja_JP.EUC-JP