summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2016-06-30 10:47:24 +0200
committerLudovic Courtès <ludo@gnu.org>2016-06-30 10:47:24 +0200
commitd2375c4330c43db3336d275cc55f23fe2aff9d32 (patch)
tree16446276e8d45d51770eb5e7bf28428cfdd1ef21
parentd9ecec9b87d435b5b503605fb0ad55530052bb19 (diff)
downloadpatches-d2375c4330c43db3336d275cc55f23fe2aff9d32.tar
patches-d2375c4330c43db3336d275cc55f23fe2aff9d32.tar.gz
gnu: mit-krb5: Disable tests on all 32-bit platforms.
* gnu/packages/mit-krb5.scm (mit-krb5)[arguments]: Change #:tests? to true only on x86_64-linux.
-rw-r--r--gnu/packages/mit-krb5.scm6
1 files changed, 3 insertions, 3 deletions
diff --git a/gnu/packages/mit-krb5.scm b/gnu/packages/mit-krb5.scm
index 8fea060bf6..2b8839c7e9 100644
--- a/gnu/packages/mit-krb5.scm
+++ b/gnu/packages/mit-krb5.scm
@@ -51,9 +51,9 @@
;; Likewise with tests.
#:parallel-tests? #f
- ;; XXX: On i686, 'kdb5_util' hangs on an fcntl/F_SETLKW call while
- ;; running the tests in 'src/tests'.
- #:tests? ,(not (string=? (%current-system) "i686-linux"))
+ ;; XXX: On 32-bit systems, 'kdb5_util' hangs on an fcntl/F_SETLKW call
+ ;; while running the tests in 'src/tests'.
+ #:tests? ,(string=? (%current-system) "x86_64-linux")
#:phases
(modify-phases %standard-phases