summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVagrant Cascadian <vagrant@debian.org>2019-12-16 21:20:53 +0000
committerVagrant Cascadian <vagrant@debian.org>2019-12-16 14:35:16 -0800
commitd08c3e51ab62575e722aec24fba42a0cb84198cc (patch)
tree2f9d64683091caeb7f2049f42e333ca89b42eaa6
parentb9676a4bbb201f32970818cc8cbbe2bcfc61e829 (diff)
downloadpatches-d08c3e51ab62575e722aec24fba42a0cb84198cc.tar
patches-d08c3e51ab62575e722aec24fba42a0cb84198cc.tar.gz
gnu: electron-cash: Update to 4.0.12.
* gnu/packages/finanace (electron-cash): Update to 4.0.12. [source] switch to git. [inputs] Add libsecp256k1. [arguments] Add phase patching to use libsecp256k1 from inputs.
-rw-r--r--gnu/packages/finance.scm36
1 files changed, 22 insertions, 14 deletions
diff --git a/gnu/packages/finance.scm b/gnu/packages/finance.scm
index 5588fe00ea..637a4dc522 100644
--- a/gnu/packages/finance.scm
+++ b/gnu/packages/finance.scm
@@ -445,28 +445,36 @@ other machines/servers. Electrum does not download the Bitcoin blockchain.")
(package
(inherit electrum)
(name "electron-cash")
- (version "4.0.10")
+ (version "4.0.12")
(source
(origin
- (method url-fetch)
- (uri (string-append "https://electroncash.org/downloads/"
- version
- "/win-linux/Electron-Cash-"
- version
- ".tar.gz"))
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/Electron-Cash/Electron-Cash.git")
+ (commit version)))
+ (file-name (git-file-name name version))
(sha256
(base32
- "1rcywlma6hk52ymisx536jvkdwa73rhn1jxhsbs4wbvajl90w9s8"))
- (modules '((guix build utils)))
- (snippet
- '(begin
- ;; Delete the bundled dependencies.
- (delete-file-recursively "packages")
- #t))))
+ "0gidrx8499v7rig7ljhd70wssshs1qm0gp1553g70i323hcbf62x"))))
(inputs
`(,@(package-inputs electrum)
+ ("libsecp256k1", libsecp256k1)
("python-dateutil", python-dateutil)
("python-dnspython", python-dnspython)))
+ (arguments
+ `(#:tests? #f ;; package doesn't have any tests
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'use-libsecp256k1-input
+ (lambda* (#:key inputs #:allow-other-keys)
+ (substitute* "lib/secp256k1.py"
+ (("library_paths = .* 'libsecp256k1.so.0'.")
+ (string-append "library_paths = ('" (assoc-ref inputs "libsecp256k1") "/lib/libsecp256k1.so.0'")))))
+ (add-before 'build 'patch-home
+ (lambda* (#:key outputs #:allow-other-keys)
+ (substitute* "setup.py"
+ (("~/.local/share")
+ (string-append (assoc-ref outputs "out") "/local/share"))))))))
(home-page "https://electroncash.org/")
(synopsis "Bitcoin Cash wallet")
(description