summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2020-01-23 21:13:42 +0100
committerHartmut Goebel <h.goebel@crazy-compilers.com>2020-01-28 13:03:08 +0100
commitcd165d105a35da9094b70d0e5d5320a4a6ac8c0d (patch)
treea4ab3240d7e81a0e324b880094a8e88a70d5e6c4
parent8377512e0c36146f55bde044e2f9b004c7482236 (diff)
downloadpatches-cd165d105a35da9094b70d0e5d5320a4a6ac8c0d.tar
patches-cd165d105a35da9094b70d0e5d5320a4a6ac8c0d.tar.gz
gnu: Cleanup KDE packages to use the update qt-build-system.
* gnu/packages/kde.scm (grantleetheme): [arguments] Remove. (kdeconnect)[arguments]<phases>{check-setup}: Remove. libkdegames: Use qt-build-system. [arguments]: Remove. * gnu/packages/kde-frameworks.scm (kguiaddons, kitemmodels, kitemviews, kplotting, sonnet, kcompletion, kcrash, kdesignerplugin, kglobalaccel, kparts, ktextwidgets, khtml, kmediaplayer): Use qt-build-system. [arguments]: Remove. (kpeople): Use qt-build-system. [arguments]<phases>: Remove. (kconfigwidgets, kwidgetsaddons) Use qt-build-system. [arguments]<phases>{check-setup}: Remove. * gnu/packages/kde-plasma.scm (kdecoration) Use qt-build-system. [arguments]: Remove. (libkscreen): Use qt-build-system. [arguments]<phases>: Remove. (libksysguard): Use qt-build-system. [arguments]<phases>{check-setup}: Remove. * gnu/packages/kde-utils.scm (kronometer, rsibreak): [arguments] Remove.
-rw-r--r--gnu/packages/kde-frameworks.scm158
-rw-r--r--gnu/packages/kde-plasma.scm27
-rw-r--r--gnu/packages/kde-utils.scm16
-rw-r--r--gnu/packages/kde.scm25
4 files changed, 25 insertions, 201 deletions
diff --git a/gnu/packages/kde-frameworks.scm b/gnu/packages/kde-frameworks.scm
index 9230bb71c0..aab54ec4fb 100644
--- a/gnu/packages/kde-frameworks.scm
+++ b/gnu/packages/kde-frameworks.scm
@@ -24,6 +24,7 @@
(define-module (gnu packages kde-frameworks)
#:use-module (guix build-system cmake)
+ #:use-module (guix build-system qt)
#:use-module (guix download)
#:use-module ((guix licenses) #:prefix license:)
#:use-module (guix packages)
@@ -702,7 +703,7 @@ infrastructure.")
(sha256
(base32
"0k22kargqxf0j09wzk1x90b526npj8a0210ilk0n1k6spc8xa6mr"))))
- (build-system cmake-build-system)
+ (build-system qt-build-system)
;; TODO: Build packages for the Python bindings. Ideally this will be
;; done for all versions of python guix supports. Requires python,
;; python-sip, clang-python, libclang. Requires python-2 in all cases for
@@ -713,14 +714,6 @@ infrastructure.")
(inputs
`(("qtbase" ,qtbase)
("qtx11extras" ,qtx11extras)))
- (arguments
- `(#:phases
- (modify-phases %standard-phases
- (add-before 'check 'check-setup
- (lambda _
- ;; make Qt render "offscreen", required for tests
- (setenv "QT_QPA_PLATFORM" "offscreen")
- #t)))))
(home-page "https://community.kde.org/Frameworks")
(synopsis "Utilities for graphical user interfaces")
(description "The KDE GUI addons provide utilities for graphical user
@@ -885,20 +878,12 @@ of applications that follow the Kirigami Human Interface Guidelines.")
(sha256
(base32
"10bhg0db9gdg2hlc02ngg1i2q7a99862d5973hxqzf620d28p5rd"))))
- (build-system cmake-build-system)
+ (build-system qt-build-system)
(native-inputs
`(("extra-cmake-modules" ,extra-cmake-modules)))
(inputs
`(("qtbase" ,qtbase)
("qtdeclarative" ,qtdeclarative)))
- (arguments
- `(#:phases
- (modify-phases %standard-phases
- (add-before 'check 'check-setup
- (lambda _
- ;; make Qt render "offscreen", required for tests
- (setenv "QT_QPA_PLATFORM" "offscreen")
- #t)))))
(home-page "https://community.kde.org/Frameworks")
(synopsis "Set of item models extending the Qt model-view framework")
(description "KItemModels provides the following models:
@@ -944,21 +929,12 @@ model to observers
(sha256
(base32
"15h0w16wgj94kxz4vgjb34i3pyx5w1f2npj86j4d2sa0mxxpmqyz"))))
- (build-system cmake-build-system)
+ (build-system qt-build-system)
(native-inputs
`(("extra-cmake-modules" ,extra-cmake-modules)
("qttools" ,qttools)))
(inputs
`(("qtbase" ,qtbase)))
- (arguments
- `(#:phases
- (modify-phases %standard-phases
- (add-before 'check 'check-setup
- (lambda _
- (setenv "DBUS_FATAL_WARNINGS" "0")
- ;; make Qt render "offscreen", required for tests
- (setenv "QT_QPA_PLATFORM" "offscreen")
- #t)))))
(home-page "https://community.kde.org/Frameworks")
(synopsis "Set of item views extending the Qt model-view framework")
(description "KItemViews includes a set of views, which can be used with
@@ -979,20 +955,12 @@ to flat and hierarchical lists.")
(sha256
(base32
"11kpq34j37c1gsvj5nxhkc31bw8gw2n7nkqsfx87jw9f4v2vhmr9"))))
- (build-system cmake-build-system)
+ (build-system qt-build-system)
(native-inputs
`(("extra-cmake-modules" ,extra-cmake-modules)))
(inputs
`(("qtbase" ,qtbase)
("qttools" ,qttools)))
- (arguments
- `(#:phases
- (modify-phases %standard-phases
- (add-before 'check 'check-setup
- (lambda _ ; kplotting
- ;; make Qt render "offscreen", required for tests
- (setenv "QT_QPA_PLATFORM" "offscreen")
- #t)))))
(home-page "https://community.kde.org/Frameworks")
(synopsis "Data plotting library")
(description "KPlotWidget is a QWidget-derived class that provides a virtual
@@ -1104,7 +1072,7 @@ represented by a QPoint or a QSize.")
(sha256
(base32
"1nzgv3v3kyq5jm2b9xri6qjawspr9ycxhskfvj8kkgr46dr35qyc"))))
- (build-system cmake-build-system)
+ (build-system qt-build-system)
(native-inputs
`(("extra-cmake-modules" ,extra-cmake-modules)
("qttools" ,qttools)
@@ -1114,12 +1082,6 @@ represented by a QPoint or a QSize.")
(arguments
`(#:phases
(modify-phases %standard-phases
- (add-before 'check 'check-setup
- (lambda _
- ;; make Qt render "offscreen", required for tests
- (setenv "QT_QPA_PLATFORM" "offscreen")
- (setenv "DBUS_FATAL_WARNINGS" "0")
- #t))
(add-before 'check 'start-xorg-server
(lambda* (#:key inputs #:allow-other-keys)
;; The test suite requires a running X server.
@@ -1414,15 +1376,7 @@ system.")
(sha256
(base32
"0gqxmyxmwn2rs9f8x2z8pfmbx0mvkyh7nalnsmfqkph8f0fja9ig"))))
- (build-system cmake-build-system)
- (arguments
- `(#:phases
- (modify-phases %standard-phases
- (add-before 'check 'check-setup
- (lambda _
- ;; make Qt render "offscreen", required for tests
- (setenv "QT_QPA_PLATFORM" "offscreen")
- #t)))))
+ (build-system qt-build-system)
(native-inputs
`(("extra-cmake-modules" ,extra-cmake-modules)
("pkg-config" ,pkg-config)
@@ -1573,7 +1527,7 @@ utilities.")
(sha256
(base32
"10ggypg09acc19gkvxsigfsaq8s5vqv64ada307blpzy8j74bisb"))))
- (build-system cmake-build-system)
+ (build-system qt-build-system)
(native-inputs
`(("extra-cmake-modules" ,extra-cmake-modules)
("qttools" ,qttools)))
@@ -1581,14 +1535,6 @@ utilities.")
`(("kconfig" ,kconfig)
("kwidgetsaddons" ,kwidgetsaddons)
("qtbase" ,qtbase)))
- (arguments
- `(#:phases
- (modify-phases %standard-phases
- (add-before 'check 'check-setup
- (lambda _
- ;; make Qt render "offscreen", required for tests
- (setenv "QT_QPA_PLATFORM" "offscreen")
- #t)))))
(home-page "https://community.kde.org/Frameworks")
(synopsis "Powerful autocompletion framework and widgets")
(description "This framework helps implement autocompletion in Qt-based
@@ -1653,7 +1599,7 @@ localized country name to ISO 3166-1 alpha 2 code mapping and vice verca.
(sha256
(base32
"1xl3bzxfchfafcplil3g07gq1a3fnwx1i40bxp4jfsgb8d8slfwc"))))
- (build-system cmake-build-system)
+ (build-system qt-build-system)
(native-inputs
`(("extra-cmake-modules" ,extra-cmake-modules)))
(inputs
@@ -1661,14 +1607,6 @@ localized country name to ISO 3166-1 alpha 2 code mapping and vice verca.
("kwindowsystem" ,kwindowsystem)
("qtbase" ,qtbase)
("qtx11extras" ,qtx11extras)))
- (arguments
- `(#:phases
- (modify-phases %standard-phases
- (add-before 'check 'check-setup
- (lambda _
- ;; make Qt render "offscreen", required for tests
- (setenv "QT_QPA_PLATFORM" "offscreen")
- #t)))))
(home-page "https://community.kde.org/Frameworks")
(synopsis "Graceful handling of application crashes")
(description "KCrash provides support for intercepting and handling
@@ -2291,7 +2229,7 @@ KCModules can be created with the KConfigWidgets framework.")
(sha256
(base32
"098xdfvnyz9bdkc6iyq5r2s4vkfdhbrri4015yzbs73j4f2wcxz5"))))
- (build-system cmake-build-system)
+ (build-system qt-build-system)
(propagated-inputs
`(("kauth" ,kauth)
("kcodecs" ,kcodecs)
@@ -2316,11 +2254,6 @@ KCModules can be created with the KConfigWidgets framework.")
;; make QDirIterator follow symlinks
(("^\\s*(QDirIterator it\\(.*, QDirIterator::Subdirectories)(\\);)" _ a b)
(string-append a " | QDirIterator::FollowSymlinks" b)))
- #t))
- (add-before 'check 'check-setup
- (lambda _
- ;; make Qt render "offscreen", required for tests
- (setenv "QT_QPA_PLATFORM" "offscreen")
#t)))))
(home-page "https://community.kde.org/Frameworks")
(synopsis "Widgets for configuration dialogs")
@@ -2439,7 +2372,7 @@ started on demand.")
(sha256
(base32
"1w7glszd82iyw6kxzmp0568rm3qfadi7vw7gfxg4c15w5ikkvxn9"))))
- (build-system cmake-build-system)
+ (build-system qt-build-system)
(native-inputs
`(("extra-cmake-modules" ,extra-cmake-modules)
("qttools" ,qttools)))
@@ -2461,14 +2394,6 @@ started on demand.")
("kxmlgui" ,kxmlgui)
("qtwebkit" ,qtwebkit)
("sonnet" ,sonnet)))
- (arguments
- `(#:phases
- (modify-phases %standard-phases
- (add-before 'check 'check-setup
- (lambda _
- ;; make Qt render "offscreen", required for tests
- (setenv "QT_QPA_PLATFORM" "offscreen")
- #t)))))
(home-page "https://community.kde.org/Frameworks")
(synopsis "Integrating KDE frameworks widgets with Qt Designer")
(description "This framework provides plugins for Qt Designer that allow it
@@ -2594,7 +2519,7 @@ emoticons coming from different providers.")
(sha256
(base32
"1xpfvwnrj81mk3di02n37b469gxzmnk89icmcz6wwyk54m86fw76"))))
- (build-system cmake-build-system)
+ (build-system qt-build-system)
(native-inputs
`(("extra-cmake-modules" ,extra-cmake-modules)
("pkg-config" ,pkg-config)
@@ -2610,14 +2535,6 @@ emoticons coming from different providers.")
("qtbase" ,qtbase)
("qtx11extras" ,qtx11extras)
("xcb-util-keysyms" ,xcb-util-keysyms)))
- (arguments
- `(#:phases
- (modify-phases %standard-phases
- (add-before 'check 'check-setup
- (lambda _
- ;; make Qt render "offscreen", required for tests
- (setenv "QT_QPA_PLATFORM" "offscreen")
- #t)))))
(home-page "https://community.kde.org/Frameworks")
(synopsis "Global desktop keyboard shortcuts")
(description "KGlobalAccel allows you to have global accelerators that are
@@ -2947,7 +2864,7 @@ notifications which can be embedded in your application.")
(sha256
(base32
"0md0349r4mdm2r04p5s3pgm17v4w40r3kz58lzp6qfcw25b969nw"))))
- (build-system cmake-build-system)
+ (build-system qt-build-system)
(propagated-inputs
`(("kio" ,kio)
("ktextwidgets" ,ktextwidgets)
@@ -2972,14 +2889,6 @@ notifications which can be embedded in your application.")
("qtbase" ,qtbase)
("solid" ,solid)
("sonnet" ,sonnet)))
- (arguments
- `(#:phases
- (modify-phases %standard-phases
- (add-before 'check 'check-setup
- (lambda _
- ;; make Qt render "offscreen", required for tests
- (setenv "QT_QPA_PLATFORM" "offscreen")
- #t)))))
(home-page "https://community.kde.org/Frameworks")
(synopsis "Plugin framework for user interface components")
(description "This library implements the framework for KDE parts, which are
@@ -2999,7 +2908,7 @@ widgets with a user-interface defined in terms of actions.")
(sha256
(base32
"1q2hh2i8hd638p907g0srdxmxm9h2ay91dmhslqzcgwnlhln4gfl"))))
- (build-system cmake-build-system)
+ (build-system qt-build-system)
(native-inputs
`(("extra-cmake-modules" ,extra-cmake-modules)))
(inputs
@@ -3012,14 +2921,7 @@ widgets with a user-interface defined in terms of actions.")
("qtbase" ,qtbase)
("qtdeclarative" ,qtdeclarative)))
(arguments
- `(#:tests? #f ; FIXME: 1/3 tests fail.
- #:phases
- (modify-phases %standard-phases
- (add-before 'check 'check-setup
- (lambda _
- ;; make Qt render "offscreen", required for tests
- (setenv "QT_QPA_PLATFORM" "offscreen")
- #t)))))
+ `(#:tests? #f)) ; FIXME: 1/3 tests fail.
(home-page "https://community.kde.org/Frameworks")
(synopsis "Provides access to all contacts and aggregates them by person")
(description "KPeople offers unified access to our contacts from different
@@ -3252,7 +3154,7 @@ library.")
(sha256
(base32
"1qb1mad5bg19xwykzpwk2b3s505ka4jkg0fsi56ri57wq8gv4qha"))))
- (build-system cmake-build-system)
+ (build-system qt-build-system)
(propagated-inputs
`(("ki18n" ,ki18n)
("sonnet" ,sonnet)))
@@ -3272,14 +3174,6 @@ library.")
("kwindowsystem" ,kwindowsystem)
("qtbase" ,qtbase)
("qtspeech" ,qtspeech)))
- (arguments
- `(#:phases
- (modify-phases %standard-phases
- (add-before 'check 'check-setup
- (lambda _
- ;; make Qt render "offscreen", required for tests
- (setenv "QT_QPA_PLATFORM" "offscreen")
- #t)))))
(home-page "https://community.kde.org/Frameworks")
(synopsis "Text editing widgets")
(description "KTextWidgets provides widgets for displaying and editing text.
@@ -3747,7 +3641,7 @@ http://community.kde.org/Frameworks/Porting_Notes should help with this.")
name "-" version ".tar.xz"))
(sha256
(base32 "15f77r6dxkkvi2vxvxlwa7qz3whmz229g79bgadiwffmzxja0ywd"))))
- (build-system cmake-build-system)
+ (build-system qt-build-system)
(native-inputs
`(("extra-cmake-modules" ,extra-cmake-modules)
("perl" ,perl)))
@@ -3775,14 +3669,6 @@ http://community.kde.org/Frameworks/Porting_Notes should help with this.")
("qtbase" ,qtbase)
("qtx11extras" ,qtx11extras)
("sonnet" ,sonnet)))
- (arguments
- `(#:phases
- (modify-phases %standard-phases
- (add-before 'check 'check-setup
- (lambda _
- ;; Make Qt render "offscreen", required for tests
- (setenv "QT_QPA_PLATFORM" "offscreen")
- #t)))))
(home-page "https://community.kde.org/Frameworks")
(synopsis "KDE Frameworks 5 HTML widget and component")
(description "KHTML is a web rendering engine, based on the KParts
@@ -3868,7 +3754,7 @@ QObjects, so you can script your applications.")
name "-" version ".tar.xz"))
(sha256
(base32 "19v53h3lkys3ryrjacrdng9ak91g03b9s986xhnw1r84zy242kdm"))))
- (build-system cmake-build-system)
+ (build-system qt-build-system)
(native-inputs
`(("extra-cmake-modules" ,extra-cmake-modules)
("kdoctools" ,kdoctools)
@@ -3883,14 +3769,6 @@ QObjects, so you can script your applications.")
("kwidgetsaddons" ,kwidgetsaddons)
("kxmlgui" ,kxmlgui)
("qtbase" ,qtbase)))
- (arguments
- `(#:phases
- (modify-phases %standard-phases
- (add-before 'check 'check-setup
- (lambda _
- ;; Make Qt render "offscreen", required for tests
- (setenv "QT_QPA_PLATFORM" "offscreen")
- #t)))))
(home-page "https://community.kde.org/Frameworks")
(synopsis "KDE Frameworks 5 plugin interface for media player features")
(description "KMediaPlayer builds on the KParts framework to provide a
diff --git a/gnu/packages/kde-plasma.scm b/gnu/packages/kde-plasma.scm
index e4360362db..a04b2f0279 100644
--- a/gnu/packages/kde-plasma.scm
+++ b/gnu/packages/kde-plasma.scm
@@ -25,6 +25,7 @@
#:use-module (guix download)
#:use-module ((guix licenses) #:prefix license:)
#:use-module (guix build-system cmake)
+ #:use-module (guix build-system qt)
#:use-module (gnu packages compression)
#:use-module (gnu packages freedesktop)
#:use-module (gnu packages glib)
@@ -45,17 +46,12 @@
(sha256
(base32
"0rljpywpaqmar13jijphkpc9k1crma476j9my0d00hfrjil5xlnn"))))
- (build-system cmake-build-system)
+ (build-system qt-build-system)
(native-inputs
`(("extra-cmake-modules" ,extra-cmake-modules)))
(inputs
`(("ki18n" ,ki18n)
("qtbase" ,qtbase)))
- (arguments
- `(#:phases
- (modify-phases %standard-phases
- (add-before 'check 'check-setup
- (lambda _ (setenv "QT_QPA_PLATFORM" "offscreen") #t)))))
(home-page "https://cgit.kde.org/kdecoration.git")
(synopsis "Plugin based library to create window decorations")
(description "KDecoration is a library to create window decorations.
@@ -137,7 +133,7 @@ manager which re-parents a Client window to a window decoration frame.")
name "-" version ".tar.xz"))
(sha256
(base32 "0znxfqqyyij6i4dp95gf5g4vrhg4jsshgh2k13ldy294kby2mxw0"))))
- (build-system cmake-build-system)
+ (build-system qt-build-system)
(native-inputs
`(("extra-cmake-modules" ,extra-cmake-modules)
;; For testing.
@@ -148,16 +144,7 @@ manager which re-parents a Client window to a window decoration frame.")
("qtbase" ,qtbase)
("qtx11extras" ,qtx11extras)))
(arguments
- '(#:tests? #f ; FIXME: 55% tests passed, 5 tests failed out of 11
- #:phases
- (modify-phases %standard-phases
- (add-before 'check 'pre-check
- (lambda _
- ;; For the missing '/etc/machine-id'.
- (setenv "DBUS_FATAL_WARNINGS" "0")
- ;; Run the tests offscreen.
- (setenv "QT_QPA_PLATFORM" "offscreen")
- #t)))))
+ '(#:tests? #f)) ; FIXME: 55% tests passed, 5 tests failed out of 11
(home-page "https://community.kde.org/Solid/Projects/ScreenManagement")
(synopsis "KDE's screen management software")
(description "KScreen is the new screen management software for KDE Plasma
@@ -199,7 +186,7 @@ basic needs and easy to configure for those who want special setups.")
("qtx11extras" ,qtx11extras)
("plasma" ,plasma-framework)
("zlib" ,zlib)))
- (build-system cmake-build-system)
+ (build-system qt-build-system)
(arguments
`(#:configure-flags
`(,(string-append "-DKDE_INSTALL_DATADIR="
@@ -212,10 +199,6 @@ basic needs and easy to configure for those who want special setups.")
;; KF5AuthConfig.cmake.in contains this already.
(substitute* "processcore/CMakeLists.txt"
(("KAUTH_HELPER_INSTALL_DIR") "KDE_INSTALL_LIBEXECDIR"))))
- (add-before 'check 'check-setup
- (lambda _
- ;; make Qt render "offscreen", required for tests
- (setenv "QT_QPA_PLATFORM" "offscreen")))
(replace 'check
(lambda _
;; TODO: Fix this failing test-case
diff --git a/gnu/packages/kde-utils.scm b/gnu/packages/kde-utils.scm
index 9005b5014a..38bdfbfaba 100644
--- a/gnu/packages/kde-utils.scm
+++ b/gnu/packages/kde-utils.scm
@@ -233,14 +233,6 @@ sentences to be re-spoken.")
("kxmlgui" ,kxmlgui)
("oxygen-icons" ,oxygen-icons) ;; default icon set
("qtbase" ,qtbase)))
- (arguments
- `(#:phases
- (modify-phases %standard-phases
- (add-before 'check 'check-setup
- (lambda _
- ;; make Qt render "offscreen", required for tests
- (setenv "QT_QPA_PLATFORM" "offscreen")
- #t)))))
(home-page "https://kde.org/applications/utilities/org.kde.kronometer")
(synopsis "Simple stopwatch application")
(description "Kronometer is a stopwatch application. It features the
@@ -399,14 +391,6 @@ redone.")
("kxmlgui" ,kxmlgui)
("oxygen-icons" ,oxygen-icons) ;; default icon set
("qtbase" ,qtbase)))
- (arguments
- `(#:phases
- (modify-phases %standard-phases
- (add-before 'check 'check-setup
- (lambda _
- ;; make Qt render "offscreen", required for tests
- (setenv "QT_QPA_PLATFORM" "offscreen")
- #t)))))
(home-page "https://kde.org/applications/utilities/org.kde.rsibreak")
(synopsis "Assists in the Recovery and Prevention of Repetitive Strain
Injury")
diff --git a/gnu/packages/kde.scm b/gnu/packages/kde.scm
index bb5c25014e..0c62fd9dba 100644
--- a/gnu/packages/kde.scm
+++ b/gnu/packages/kde.scm
@@ -89,13 +89,6 @@
("kiconthemes" ,kiconthemes)
("knewstuff" ,knewstuff)
("qtbase" ,qtbase)))
- (arguments
- `(#:phases
- (modify-phases %standard-phases
- (add-before 'check 'check-setup
- (lambda _
- (setenv "QT_QPA_PLATFORM" "offscreen")
- #t)))))
(home-page "https://cgit.kde.org/grantleetheme.git")
(synopsis "Library providing Grantlee theme support")
(description "This library provides Grantlee theme support.")
@@ -521,13 +514,7 @@ different notification systems.")
(build-system qt-build-system)
(arguments
`(#:configure-flags '("-DBUILD_TESTING=ON")
- #:tests? #f ; tests fail hard in our build environment
- #:phases
- (modify-phases %standard-phases
- (add-before 'check 'check-setup
- (lambda _
- (setenv "QT_QPA_PLATFORM" "offscreen")
- #t)))))
+ #:tests? #f)) ; tests fail hard in our build environment
(native-inputs
`(("extra-cmake-modules" ,extra-cmake-modules)
("kdoctools" ,kdoctools)
@@ -644,7 +631,7 @@ Python, PHP, and Perl.")
"/src/libkdegames-" version ".tar.xz"))
(sha256
(base32 "12dvkmjgbi8dp9y55zmx1pw3zr2i374c4vn3mfn9r31bf06dr701"))))
- (build-system cmake-build-system)
+ (build-system qt-build-system)
(native-inputs
`(("extra-cmake-modules" ,extra-cmake-modules)))
(inputs
@@ -674,14 +661,6 @@ Python, PHP, and Perl.")
("qtbase" ,qtbase)
("qtdeclarative" ,qtdeclarative)
("qtsvg" ,qtsvg)))
- (arguments
- `(#:phases
- (modify-phases %standard-phases
- (add-before 'check 'check-setup
- (lambda _
- ;; make Qt render "offscreen", required for tests
- (setenv "QT_QPA_PLATFORM" "offscreen")
- #t)))))
(home-page "https://games.kde.org/")
(synopsis "Runtime library for kdegames")
(description "Runtime library for kdegames")