summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2020-01-18 12:52:51 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2020-01-19 06:09:01 +0100
commitc2c73f583d401a84e94a1e1e5b61da9c41f15683 (patch)
treea7a78f537c217f1c4921a4b879fab93a0f8deab0
parent4f620bbf620e0848b1b29874e04bc6a4d6eee4f8 (diff)
downloadpatches-c2c73f583d401a84e94a1e1e5b61da9c41f15683.tar
patches-c2c73f583d401a84e94a1e1e5b61da9c41f15683.tar.gz
Use HTTPS for www.emacswiki.org.
* doc/contributing.texi (The Perfect Setup): Use HTTPS for ParEdit wiki page. * gnu/packages/emacs-xyz.scm (emacs-wget, emacs-iedit)[home-page]: Use HTTPS. (emacs-transpose-frame)[source]: Likewise.
-rw-r--r--doc/contributing.texi2
-rw-r--r--gnu/packages/emacs-xyz.scm6
2 files changed, 4 insertions, 4 deletions
diff --git a/doc/contributing.texi b/doc/contributing.texi
index 5d5d50c3c0..c6586a2adf 100644
--- a/doc/contributing.texi
+++ b/doc/contributing.texi
@@ -240,7 +240,7 @@ that it finds source files from your checkout:
To actually edit the code, Emacs already has a neat Scheme mode. But in
addition to that, you must not miss
-@url{http://www.emacswiki.org/emacs/ParEdit, Paredit}. It provides
+@url{https://www.emacswiki.org/emacs/ParEdit, Paredit}. It provides
facilities to directly operate on the syntax tree, such as raising an
s-expression or wrapping it, swallowing or rejecting the following
s-expression, etc.
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 32e8ae17da..34ea293ac6 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -1243,7 +1243,7 @@ or unexpected behavior inside an elisp configuration file (typically
"wget" (string-append (assoc-ref outputs "out")
"/share/emacs/site-lisp/"))
#t)))))
- (home-page "http://www.emacswiki.org/emacs/EmacsWget")
+ (home-page "https://www.emacswiki.org/emacs/EmacsWget")
(synopsis "Simple file downloader for Emacs based on wget")
(description
"Emacs-wget is an emacs interface for the wget file downloader.")
@@ -5669,7 +5669,7 @@ highlighted. Pressing that character will switch to that window.")
(sha256
(base32 "0wr3w2id95wx2rma8n1ifjrv9rx37ly26ijc5zi58id0yrip3hnc"))))
(build-system emacs-build-system)
- (home-page "http://www.emacswiki.org/emacs/Iedit")
+ (home-page "https://www.emacswiki.org/emacs/Iedit")
(synopsis "Edit multiple regions in the same way simultaneously")
(description
"This package is an Emacs minor mode and allows you to edit one
@@ -9782,7 +9782,7 @@ with gnuplot.")
(source
(origin
(method url-fetch)
- (uri "http://www.emacswiki.org/emacs/download/transpose-frame.el")
+ (uri "https://www.emacswiki.org/emacs/download/transpose-frame.el")
(file-name (string-append "transpose-frame-" version ".el"))
(sha256
(base32