summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2020-02-17 15:48:37 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2020-02-17 17:12:56 +0100
commitb614a2239384c16111e0c03317c9fbeee5728cb2 (patch)
treeabd4420deeda0f358dc62de87cec4d1b3a959581
parent5bcf4d4c35600d1964e4464aef7e7b63c9eced49 (diff)
downloadpatches-b614a2239384c16111e0c03317c9fbeee5728cb2.tar
patches-b614a2239384c16111e0c03317c9fbeee5728cb2.tar.gz
gnu: ebtables: Update to 2.0.11.
* gnu/packages/linux.scm (ebtables): Update to 2.0.11. [arguments]: Remove them all.
-rw-r--r--gnu/packages/linux.scm36
1 files changed, 3 insertions, 33 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 1c36aefb45..a1920dba35 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -1843,46 +1843,16 @@ Both commands are targeted at system administrators.")
(define-public ebtables
(package
(name "ebtables")
- (version "2.0.10-4")
+ (version "2.0.11")
(source (origin
(method url-fetch)
(uri (string-append
- "mirror://netfilter.org/ebtables/ebtables-v"
+ "mirror://netfilter.org/ebtables/ebtables-"
version ".tar.gz"))
(sha256
(base32
- "0pa5ljlk970yfyhpf3iqwfpbc30j8mgn90fapw9cfz909x47nvyw"))))
+ "0apxgmkhsk3vxn9q3libxn3dgrdljrxyy4mli2gk49m7hi3na7xp"))))
(build-system gnu-build-system)
- (arguments
- '(#:tests? #f ; no test suite
- #:make-flags
- (let* ((out (assoc-ref %outputs "out"))
- (bin (string-append out "/sbin"))
- (lib (string-append out "/lib"))
- (man (string-append out "/share/man"))
- (iptables (assoc-ref %build-inputs "iptables"))
- (ethertypes (string-append iptables "/etc/ethertypes")))
- (list (string-append "LIBDIR=" lib)
- (string-append "MANDIR=" man)
- (string-append "BINDIR=" bin)
- (string-append "ETHERTYPESFILE=" ethertypes)
- ;; With the default CFLAGS, it falis with:
- ;; communication.c:259:58: error: variable ‘ret’ set but not
- ;; used [-Werror=unused-but-set-variable]
- "CFLAGS=-Wall"))
- #:phases
- (modify-phases %standard-phases
- (replace 'configure
- ;; no configure script
- (lambda _
- (substitute* "Makefile"
- ;; Remove user and group options from install commands,
- ;; otherwise it fails with: invalid user 'root'.
- (("-o root -g root") "")
- ;; Remove 'ethertypes' from the install target.
- (("install: .*")
- "install: $(MANDIR)/man8/ebtables.8 exec scripts\n"))
- #t)))))
(inputs
`(("perl" ,perl)
("iptables" ,iptables)))